package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<City>.*)\s[^\s]+\s[0-9\-]{5,}`)
var str = `Falls Church VA 23112
Arlington Virginia 24221-2345
Arlington VIRGINIA 24221-2345
TYSON CORNER VA 232342345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}