re = /(\w+):(.*?)(?=\s+[a-zA-Z]\w+:|$)/m
str = ' event_time:2019-06-12 12:24:21.8542963 sequence_number:1 action_id:CR succeeded:true is_column_permission:false session_id:59 server_principal_id:2(...)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end