#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?P<hop>\d+)?[\h*]*(?:\[AS(?<ASN>\d*)\])?\h+(?<hostname>[\w\.]+)\h+\((?<ip>[\d+\.]+)\)\h+(?<times>.*?)\h*$"
Local $sString = "1 10.33.128.1 (10.33.128.1) 4.452 ms 3.459 ms 3.474 ms " & @CRLF & _
"6 * [AS3356] 4.68.72.218 (4.68.72.218) 12.432 ms 11.819 ms " & @CRLF & _
" * 4.68.72.218 (4.68.72.218) 12.432 ms 11.819 ms " & @CRLF & _
" 61.182.180.62 (61.182.180.62) 175.300 ms 203.001 ms"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")