$re = '/_(.*?)=/';
$str = '?_field1=param1,param2,paramX&_field2=param1,param2,paramX';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);