$re = '/,.*,\d/';
$str = 'a,b,c,x23,def,ghi,jkl,mno,pqr,stu,vxw,1z';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);