re = /[^#]\K#[^\n]*|^#[^\n]*/
str = '# comment
print "Hello, World!" # another comment'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end