use strict;
my $str = 'hello there';
my $regex = qr/(?<=.{3})./mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";