$re = '/ (?<Entity>CPU) (?<MetricName>Package Power|Core Power|SoC Power) \((?<MetricCategory>[^)]+)\)/m';
$str = 'CPU Package Power (SMU)
" (?<Entity>CPU) (?<MetricName>Package Power|Core Power|SoC Power) \\((?<MetricCategory>[^)]+)\\)"gm
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);