using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+products\/.+\/(?!\d+\-).+";
string input = @"/global/en/products/pumps/floor-pumps";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}