package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([0-9]+)\s?м²`)
var str = `1-к квартира, 39 м², 1/5 эт.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}