re = /^(?:.*[\\\/])?(src)(?=[\\\/])|[\\\/][^\\\/]+$|([\\\/])/m
str = 'src/MyEntity/Application/MyUseCase.php'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end