#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(0|[1-9]+[0-9]*) (@[^@]+@ |)([A-Za-z0-9_]+)( [^\n\r]*|)$"
Local $sString = "0 @N1@ NOTE Lorem ipsum dolor sit amet" & @CRLF & _
"0 HEAD" & @CRLF & _
"1 SOUR FTM" & @CRLF & _
"2 VERS 22.2.6.950" & @CRLF & _
"1 DEST FTM" & @CRLF & _
"1 DATE 31 MAR 2017" & @CRLF & _
"1 CHAR UTF-8" & @CRLF & _
"3 _LINK http://www.facebook.com/1247584965" & @CRLF & _
"2 SOUR @S122@" & @CRLF & _
"3 PAGE Facebook update - David Hatch - 6/5/2013" & @CRLF & _
"3 _LINK http://www.facebook.com/1247584965" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1 RESI" & @CRLF & _
"2 DATE BET 1935 AND 1993" & @CRLF & _
"2 PLAC San Francisco, California, USA" & @CRLF & _
"1 RESI" & @CRLF & _
"2 DATE 1994" & @CRLF & _
"2 PLAC San Francisco, California, USA" & @CRLF & _
"2 SOUR @S605@" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT Birth date: 20 Sep 1966 Birth place: Residence date: 1994 " & @CRLF & _
"5 CONC Residence place: San Francisco, CA" & @CRLF & _
"1 RESI 106 Oakcrest Rd" & @CRLF & _
"2 DATE 26 MAR 2017" & @CRLF & _
"2 PLAC San Anselmo, Marin, California, USA" & @CRLF & _
"1 FAMS @F500@" & @CRLF & _
"1 FAMC @F656@" & @CRLF & _
"0 @I923@ INDI" & @CRLF & _
"1 NAME Vincent /Crilley/" & @CRLF & _
"1 SEX M" & @CRLF & _
"1 FAMS @F254@" & @CRLF & _
"0 @I5899@ INDI" & @CRLF & _
"1 NAME Marjorie Edna /Footitt/" & @CRLF & _
"2 SOUR @S506@" & @CRLF & _
"2 SOUR @S176@" & @CRLF & _
"2 SOUR @S168@" & @CRLF & _
"2 SOUR @S624@" & @CRLF & _
"3 DATA" & @CRLF & _
"4 TEXT Residence date: Residence place: USA" & @CRLF & _
"2 SOUR @S115@" & @CRLF & _
"3 PAGE Year: 1940; Census Place: St Paul, Ramsey, Minnesota; Roll: T627_1996; " & @CRLF & _
"4 CONC Page: 11A; Enumeration District: 90-73." & @CRLF & _
"3 DATA" & @CRLF & _
"4 _TEXT Birth date: abt 1918 Birth place: North Dakota Residence date: 1 " & @CRLF & _
"5 CONC Apr 1940 Residence place: St Paul, Ramsey, Minnesota, United States" & @CRLF & _
"2 SOUR @S607@" & @CRLF & _
"3 PAGE Year: 1920; Census Place: Carrington, Foster, North Dakota; Roll: " & @CRLF & _
"4 CONC T625_1334; Page: 13B; Enumeration District: 117; Image: ." & @CRLF & _
"3 DATA"
Local $sSubst = "\n2($2) 3($3) 4($4) 5($5) 6($6) 7($7) \n\n8($8) 9($9) 10($10) 11($11) 12($12) 13($13) 14($14) 15($15) 16($16) 18($18) 20($20) 21($21)\n\n\n\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)