$re = '`^\d{4}-(1[012]|0?[1-9])-([12][0-9]|3[01]|0?[1-9])`m';
$str = '2021-11-31';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);