$re = '/^[a-zA-Z_]+[0-9]*$/u';
$str = 'test
test2
2test';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);