package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*\bhello\s+(.*?)\s+world\b`)
var str = `dog cat hello cat dog dog hello cat world world`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}