$re = '/(?<=:)\d{4,5}/m';
$str = 'tcp.ip://Rechner1234.local.host:4840';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);