package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`Study Title: {[^}]*}`)
var str = `{\af31507 \ltrch\fcs0 \insrsid6361256 Study Title: {Test for 14431 process\'27s \u8805 1000 Testing2 14432 \u8805 8000}}{\rtlch\fcs1 \af31507 \ltrch\fcs0 \insrsid12283827`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}