re = /^(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d!#$%\-_=+<>]+$/m
str = 'jkj2#ff43#$#
jkj2#f f43#$#'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end