$re = '/\bawait\s[^()]*\([^()]*\);/m';
$str = 'await Listing.find({
Test: 1
});
await Listing.find({
Test: 1
}).lean();';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);