$re = '/^\w+\.key\.\w+$/m';
$str = 'bar.key.door
fruit.bar.key.door';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);