import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Leistung.*(?:\\n(?!Leistung).*)?";
final String string = "Leistung Armeotraining ET Anzahl 1\n"
+ "Zusatz *TextZusatz_Anf1*\n"
+ "Leistung Atemtherapie 30 Anzahl 2\n"
+ "Leistung Aktivierungsgruppe Anzahl 3\n"
+ "Zusatz *TextZusatz_Anf3*";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}