$re = '/^(?=.*0)[0-9]{12}$/m';
$str = '1234567890
12346789111
123456789012';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);