#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=\()(?:\d{4}|\d{2}-\d{2})(?=\))"
Local $sString = "random text here (00-04) more random text" & @CRLF & _
"lame text (junk data) more text (08-12)" & @CRLF & _
"random text (2008) " & @CRLF & _
"random text (2005) junk text (junk)" & @CRLF & _
"nothing important (13-15) not important (not important)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")