package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^/]{1,6})[^/]*$`)
var str = `people/capital/base/flagedbylogger5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}