package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^abc(4|20)$`)
var str = `abc4`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}