import re
regex = re.compile(r"^(?!0\d*$)\d(?:[1-9]\d*)?(?:\.\d{1,2})?$", flags=re.MULTILINE)
test_str = ("These are the scenarios that we can accept:\n"
"0.01\n"
"1.1\n"
"1.02\n"
"120.01\n\n"
"We can't accept these values\n\n"
"0023\n"
"0100\n"
".01\n"
".12\n\n"
"001.02\n"
"0000\n"
"0\n"
"00.4\n"
"0.4")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")