$re = '/(?<="(password|userword)":)("[^"]+")/m';
$str = '[{"nickName":"andy","password":"wei","userword":"weitest32123"}]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);