#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?im)((<b>([a-z]+)<\/b>)((?!<br>).)*)$"
Local $sString = "<b>word</b><br>" & @CRLF & _
"<b>word</b> <br>" & @CRLF & _
"<b>word</b> in text" & @CRLF & _
"half<b>word</b> "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")