package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\/]+)[.][^:]+:\d+:\d+`)
var str = `at LoggerService.log (/Users/apps/api/webpack:/pcs-goc-api/pcs-libs/logger/src/logger.service.ts:107:29)
at LoggerService.log (/Users/apps/api/webpack:/pcs-goc-api/pcs-libs/logger/src/zxc.qwe.js:107:29)
at LoggerService.log (/Users/apps/api/webpack:/pcs-goc-api/pcs-libs/logger/src/abc.def.qwe:107:29)
at LoggerService.log (/Users/apps/api/webpack:/pcs-goc-api/pcs-libs/logger/src/abc.def.ghi.qwe:107:29)
at LoggerService.log (/Users/apps/api/webpack:/pcs-goc-api/pcs-libs/logger/src/logger.ts:107:29) expected: logger
at LoggerService.log (/Users/apps/api/webpack:/pcs-goc-api/pcs-libs/logger/src/logger.js:107:29) expected: logger
at LoggerService.log (/Users/apps/api/webpack:/pcs-goc-api/pcs-libs/logger/src/api.logger.service.ts:107:29) expected: api.logger.service`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}