const regex = /^(?!.*\.\.)(?!.*\s\s)(?!.*,,)[A-Z][a-zA-Z.,]{2,30}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*\\.\\.)(?!.*\\s\\s)(?!.*,,)[A-Z][a-zA-Z.,]{2,30}', 'gm')
const str = `Rekha
Rekha102
Rekha..67890
Rekha,,89654`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}