# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
editor\s*\{[^{}"]*
# Repeatedly match the key-value pairs
(?:
# Match from opening to closing double quote for the 'key'
"[^\\"]*
# Handle escaped characters: \ followed by another character
(?: \\. [^\\"]* )*
"
# Then any whitespace between the 'key' and 'value'
\s+
# Match from opening to closing double quote for the 'value'
"[^\\"]*
# Handle escaped characters: \ followed by another character
(?: \\. [^\\"]* )*
"
# Match everything (especially whitespace) except these chars:
[^{}"]*
|
# Key name may or may not be within quotes
"? \w+ "? [^{}"]*
\{[^{}"]*
(?:
"[^\\"]* (?: \\. [^\\"]* )* " \s+ "[^\\"]* (?: \\. [^\\"]* )* "
[^{}"]*
)*
\} [^{}"]*
)*
\}
"""
test_str = ("\"entity\"\n"
"{\n"
" \"id\" \"5040044\"\n"
" \"classname\" \"weapon_defibrillator_spawn\"\n"
" \"angles\" \"0 0 0\"\n"
" \"body\" \"0\"\n"
" \"disableshadows\" \"0\"\n"
" \"skin\" \"0\"\n"
" \"solid\" \"6\"\n"
" \"spawnflags\" \"3\"\n"
" \"origin\" \"449.47 5797.25 2856\"\n"
" editor\n"
" {\n"
" \"color\" \"0 0 200\"\n"
" \"visgroupshown\" \"1\"\n"
" \"visgroupautoshown\" \"1\"\n"
" \"logicalpos\" \"[-13268 14500]\"\n"
" \"helptext\" \"This is a \\\"help\\\" menu.\"\n"
" }\n"
" editor\n"
" {\n"
" \"color\" \"0 0 200\"\n"
" \"visgroupshown\" \"1\"\n"
" \"visgroupautoshown\" \"1\"\n"
" \"logicalpos\" \"[-13268 14500]\"\n"
" }\n"
" editor\n"
" {\n"
" \"color\" \"0 0 200\"\n"
" \"visgroupshown\" \"1\"\n"
" \"visgroupautoshown\" \"1\"\n"
" \"logicalpos\" \"[-13268 14500]\"\n"
" \"specialchars\" \"}\"\n"
" }\n"
" editor\n"
" {\n"
" \"child\" \"0 0 200\"\n"
" \"visgroupshown\" \"1\"\n"
" \"visgroupautoshown\" \"1\"\n"
" \"logicalpos\" \"[-13268 14500]\"\n"
" subgroup\n"
" {\n"
" \"child\" \"42 42 42\"\n"
" }\n"
" }\n"
"}\n")
matches = re.finditer(regex, test_str, re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.