re = /(13[0-9]|14[01456879]|15[0-35-9]|16[2567]|17[0-8]|18[0-9]|19[0-35-9])\d{8}/m
str = 'phone17777777777number18888888888'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end