$re = '@(?:\G(?!^)|\sas\s(?=.*\'\d{2}/\d{2}/\d{4}\'$))(?:(?!\sfrom\s).)*?\K,?\s*[A-Z_]+_(?:[FRC]ID|TSP)_[A-Z_]+@m';
$str = 'select (TRIM(TAE_TSP_REC_UPDATE)) as PK,TAE_AMT_FAIR_MV,TAE_TXT_ACCT_NUM,TAE_CDE_OWNER_TYPE,TAE_DTE_AQA_ABA,TAE_RID_OWNER,TAE_FID_OWNER,TAE_CID_OWNER,TAE_TSP_REC_UPDATE from TABLE_TAX_REP where DATE(TAE_TSP_REC_UPDATE)>=\'03/31/2018\'';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;