$re = '/^[0-9]{5}-[0-9]{7}-[0-9]$/';
$str = '12345-1234567-1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);