$re = '/(?<=\.)\w{1,4}$/m';
$str = '/home/doe/flat.6df.png
C:\\windows\\home.html';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);