package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(25[0-5]|2[0-4][0-9]|[01]?[0-9][0-9]?)\.){3}(?1)$`)
var str = `22.231.113.64
22.231.113.233`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}