$re = '/^(?:(?:25[0-5]|2[0-4]\d|1?\d?\d)(?:\.(?!$)|$)){4}$/m';
$str = '1.2.3.4
172.16.254.1
255.255.255.255
255.255.255.0
9.9.9.9
999.9.9.9
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);