#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<first_name>\S+) +(?<last_name>\S+) +(?<age>\d+) +(?<street_nbr>\d+) +(?<stret_name>.*)"
Local $sString = "Amber-Rose Bowen 53 123 Machinery Rd." & @CRLF & _
"Joyce Kirkland 19 234 Cylinder Dr." & @CRLF & _
"Seb Dotson 32 3456 Surgery Ln. " & @CRLF & _
"Dominique Hough 58 654 Election Rd." & @CRLF & _
"Yasemin Mcleod 29 555 Cabinet Ave." & @CRLF & _
"Nancy Lord 80 232 Highway Rd." & @CRLF & _
"Tracy Mckenzie 72 101 Device Ave." & @CRLF & _
"Alistair Salter 25 109 Guitar Ln." & @CRLF & _
"Adeel Sears 42 222 Solitare Rd." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")