package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\()?\d{3}(\))?(-|\s)?[2-9]{1}\d{2}(-|\s)\d{4}$`)
var str = `(789) 456-1230`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}