$re = '/J.*/m';
$str = 'John
Jane
Jill
James
Jose
Jack
Julian';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);