const regex = /((\w+)\s)?((\w+)\s)?(\w+)\s(\w+)\n([^\s]+)\s([^\s]+)\s([^\s]+)\s([^\s]+)\s([^\s]+)\n/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((\\w+)\\s)?((\\w+)\\s)?(\\w+)\\s(\\w+)\\n([^\\s]+)\\s([^\\s]+)\\s([^\\s]+)\\s([^\\s]+)\\s([^\\s]+)\\n', 'gm')
const str = `ALUPAR DIVIDENDO
300 135,00 0,00 135,00 31/05/2022
ALUPAR DIVIDENDO
300 135,00 0,00 135,00 31/08/2022
ALUPAR DIVIDENDO
300 99,00 0,00 99,00 30/11/2022
ALUPAR TOTAL
-- 369,00 0,00 369,00 --
B3 JCP
900 44,79 6,71 38,08 07/01/2022
B3 DIVIDENDO
900 118,07 0,00 118,07 08/04/2022
B3 JCP
900 45,26 6,78 38,48 08/04/2022
B3 DIVIDENDO
900 62,88 0,00 62,88 08/07/2022
B3 JCP
900 54,81 8,22 46,59 08/07/2022
B3 DIVIDENDO
900 25,30 0,00 25,30 07/10/2022
B3 JCP
900 49,28 7,39 41,89 07/10/2022
B3 DIVIDENDO
900 21,78 0,00 21,78 29/12/2022
B3 TOTAL
-- 422,17 29,10 393,07 --
BANCO INTER JCP
600 26,60 3,99 22,61 21/03/2022
BANCO INTER TOTAL
-- 26,60 3,99 22,61 --
BANRISUL JCP
600 200,33 30,04 170,29 29/03/2022
BANRISUL DIVIDENDO
600 21,96 0,00 21,96 19/05/2022
BANRISUL TOTAL
-- 222,29 30,04 192,25 --
BRASILAGRO DIVIDENDO
400 806,51 0,00 806,51 29/04/2022
BRASILAGRO DIVIDENDO
400 1.295,46 0,00 1.295,46 16/11/2022
BRASILAGRO TOTAL
-- 2.101,97 0,00 2.101,97 --
DIRECIONAL DIVIDENDO
800 376,00 0,00 376,00 25/07/2022
DIRECIONAL TOTAL
-- 376,00 0,00 376,00 --
EZTEC DIVIDENDO
503 231,54 0,00 231,54 31/03/2022
EZTEC DIVIDENDO
503 56,68 0,00 56,68 31/05/2022
EZTEC DIVIDENDO
503 45,52 0,00 45,52 31/08/2022
EZTEC DIVIDENDO
503 57,73 0,00 57,73 30/11/2022
EZTEC TOTAL
-- 391,47 0,00 391,47 --
FIAGRO VGIA RENDIMENTO
100 17,00 0,00 17,00 17/08/2022
FIAGRO VGIA RENDIMENTO
300 51,00 0,00 51,00 20/09/2022
FIAGRO VGIA SUBSCRICAO
267 0,00 0,00 0,00 29/09/2022
FIAGRO VGIA RENDIMENTO
267 1,00 0,00 1,00 20/10/2022
FIAGRO VGIA RENDIMENTO
300 48,00 0,00 48,00 20/10/2022
FIAGRO VGIA RENDIMENTO
267 37,38 0,00 37,38 21/11/2022
FIAGRO VGIA RENDIMENTO
300 42,00 0,00 42,00 21/11/2022
FIAGRO VGIA RENDIMENTO
567 79,38 0,00 79,38 19/12/2022
FIAGRO VGIA TOTAL
-- 275,76 0,00 275,76 --
FIC INFR BTG RENDIMENTO
50 100,00 0,00 100,00 21/01/2022
FIC INFR BTG RENDIMENTO
50 100,00 0,00 100,00 21/02/2022
FIC INFR BTG RENDIMENTO
50 100,00 0,00 100,00 22/03/2022
FIC INFR BTG RENDIMENTO
50 100,00 0,00 100,00 25/04/2022
FIC INFR BTG RENDIMENTO
100 100,00 0,00 100,00 25/04/2022
FIC INFR BTG RENDIMENTO
50 150,00 0,00 150,00 20/05/2022
FIC INFR BTG RENDIMENTO
100 150,00 0,00 150,00 20/05/2022
FIC INFR BTG RENDIMENTO
50 150,00 0,00 150,00 22/06/2022
FIC INFR BTG RENDIMENTO
98 147,00 0,00 147,00 22/06/2022
FIC INFR BTG RENDIMENTO
100 150,00 0,00 150,00 22/06/2022
FIC INFR BTG RENDIMENTO
2 3,50 0,00 3,50 21/07/2022
FIC INFR BTG RENDIMENTO
50 175,00 0,00 175,00 21/07/2022
FIC INFR BTG RENDIMENTO
98 171,50 0,00 171,50 21/07/2022
FIC INFR BTG RENDIMENTO
100 175,00 0,00 175,00 21/07/2022
FIC INFR BTG RENDIMENTO
2 3,50 0,00 3,50 19/08/2022
FIC INFR BTG RENDIMENTO
50 175,00 0,00 175,00 19/08/2022
FIC INFR BTG RENDIMENTO
98 171,50 0,00 171,50 19/08/2022
FIC INFR BTG RENDIMENTO
100 175,00 0,00 175,00 19/08/2022
FIC INFR BTG RENDIMENTO
2 3,50 0,00 3,50 22/09/2022
FIC INFR BTG RENDIMENTO
50 175,00 0,00 175,00 22/09/2022
FIC INFR BTG RENDIMENTO
98 171,50 0,00 171,50 22/09/2022
FIC INFR BTG RENDIMENTO
100 175,00 0,00 175,00 22/09/2022
FIC INFR BTG RENDIMENTO
2 3,00 0,00 3,00 24/10/2022
FIC INFR BTG RENDIMENTO
50 150,00 0,00 150,00 24/10/2022
FIC INFR BTG RENDIMENTO
98 147,00 0,00 147,00 24/10/2022
FIC INFR BTG RENDIMENTO
100 150,00 0,00 150,00 24/10/2022
FIC INFR BTG RENDIMENTO
2 2,60 0,00 2,60 23/11/2022
FIC INFR BTG RENDIMENTO
50 130,00 0,00 130,00 23/11/2022
FIC INFR BTG RENDIMENTO
98 127,40 0,00 127,40 23/11/2022
FIC INFR BTG RENDIMENTO
100 130,00 0,00 130,00 23/11/2022
FIC INFR BTG RENDIMENTO
2 2,10 0,00 2,10 21/12/2022
FIC INFR BTG RENDIMENTO
50 105,00 0,00 105,00 21/12/2022
FIC INFR BTG RENDIMENTO
98 102,90 0,00 102,90 21/12/2022
FIC INFR BTG RENDIMENTO
100 105,00 0,00 105,00 21/12/2022
FIC INFR BTG TOTAL
-- 3.977,00 0,00 3.977,00 --
FIC INTER RENDIMENTO
25 15,25 0,00 15,25 12/08/2022
FIC INTER RENDIMENTO
25 12,75 0,00 12,75 15/09/2022
FIC INTER RENDIMENTO
25 12,50 0,00 12,50 17/10/2022
FIC INTER RENDIMENTO
25 13,25 0,00 13,25 16/11/2022
FIC INTER RENDIMENTO
25 25,25 0,00 25,25 14/12/2022
FIC INTER TOTAL
-- 79,00 0,00 79,00 --
FII ABSOLUTO RENDIMENTO
281 168,60 0,00 168,60 07/01/2022
FII ABSOLUTO RENDIMENTO
281 168,60 0,00 168,60 07/02/2022
FII ABSOLUTO RENDIMENTO
281 168,60 0,00 168,60 08/03/2022
FII ABSOLUTO RENDIMENTO
281 168,60 0,00 168,60 07/04/2022
FII ABSOLUTO RENDIMENTO
281 182,65 0,00 182,65 06/05/2022
FII ABSOLUTO RENDIMENTO
281 210,75 0,00 210,75 07/06/2022
FII ABSOLUTO RENDIMENTO
281 224,80 0,00 224,80 07/07/2022
FII ABSOLUTO RENDIMENTO
281 210,75 0,00 210,75 05/08/2022
FII ABSOLUTO RENDIMENTO
281 196,70 0,00 196,70 08/09/2022
FII ABSOLUTO RENDIMENTO
281 196,70 0,00 196,70 07/10/2022
FII ABSOLUTO RENDIMENTO
281 174,22 0,00 174,22 08/11/2022
FII ABSOLUTO RENDIMENTO
281 174,22 0,00 174,22 07/12/2022
FII ABSOLUTO TOTAL
-- 2.245,19 0,00 2.245,19 --
FII BC FUND RENDIMENTO
227 113,50 0,00 113,50 14/01/2022
FII BC FUND RENDIMENTO
227 113,50 0,00 113,50 14/02/2022
FII BC FUND RENDIMENTO
227 113,50 0,00 113,50 15/03/2022
FII BC FUND RENDIMENTO
227 113,50 0,00 113,50 14/04/2022
FII BC FUND RENDIMENTO
227 113,50 0,00 113,50 13/05/2022
FII BC FUND RENDIMENTO
227 106,69 0,00 106,69 14/06/2022
FII BC FUND RENDIMENTO
227 106,69 0,00 106,69 14/07/2022
FII BC FUND RENDIMENTO
227 106,69 0,00 106,69 12/08/2022
FII BC FUND RENDIMENTO
227 106,69 0,00 106,69 15/09/2022
FII BC FUND RENDIMENTO
227 106,69 0,00 106,69 17/10/2022
FII BC FUND RENDIMENTO
227 106,69 0,00 106,69 16/11/2022
FII BC FUND RENDIMENTO
227 113,50 0,00 113,50 14/12/2022
FII BC FUND TOTAL
-- 1.321,14 0,00 1.321,14 --
FII BTG TAGR RENDIMENTO
10 9,40 0,00 9,40 29/04/2022
FII BTG TAGR RENDIMENTO
10 9,40 0,00 9,40 31/05/2022
FII BTG TAGR RENDIMENTO
10 7,00 0,00 7,00 30/06/2022
FII BTG TAGR RENDIMENTO
10 7,00 0,00 7,00 29/07/2022
FII BTG TAGR RENDIMENTO
10 7,00 0,00 7,00 31/08/2022
FII BTG TAGR RENDIMENTO
10 7,00 0,00 7,00 30/09/2022
FII BTG TAGR RENDIMENTO
10 8,00 0,00 8,00 31/10/2022
FII BTG TAGR RENDIMENTO
10 8,50 0,00 8,50 30/11/2022
FII BTG TAGR RENDIMENTO
10 8,50 0,00 8,50 29/12/2022
FII BTG TAGR TOTAL
-- 71,80 0,00 71,80 --
FII CAPI SEC RENDIMENTO
200 220,00 0,00 220,00 19/01/2022
FII CAPI SEC RENDIMENTO
200 220,00 0,00 220,00 17/02/2022
FII CAPI SEC RENDIMENTO
200 220,00 0,00 220,00 18/03/2022
FII CAPI SEC RENDIMENTO
200 220,00 0,00 220,00 20/04/2022
FII CAPI SEC SUBSCRICAO
23 0,00 0,00 0,00 27/04/2022
FII CAPI SEC RENDIMENTO
23 2,08 0,00 2,08 18/05/2022
FII CAPI SEC RENDIMENTO
200 216,00 0,00 216,00 18/05/2022
FII CAPI SEC RENDIMENTO
23 20,07 0,00 20,07 20/06/2022
FII CAPI SEC RENDIMENTO
200 224,00 0,00 224,00 20/06/2022
FII CAPI SEC RENDIMENTO
223 245,30 0,00 245,30 19/07/2022
FII CAPI SEC RENDIMENTO
223 245,30 0,00 245,30 17/08/2022
FII CAPI SEC RENDIMENTO
223 245,30 0,00 245,30 20/09/2022
FII CAPI SEC RENDIMENTO
223 234,15 0,00 234,15 20/10/2022
FII CAPI SEC RENDIMENTO
223 189,55 0,00 189,55 21/11/2022
FII CAPI SEC RENDIMENTO
223 82,51 0,00 82,51 19/12/2022
FII CAPI SEC TOTAL
-- 2.584,26 0,00 2.584,26 --
FII CX RBRAV RENDIMENTO
100 55,00 0,00 55,00 12/01/2022
FII CX RBRAV RENDIMENTO
100 51,00 0,00 51,00 10/02/2022
FII CX RBRAV RENDIMENTO
100 51,00 0,00 51,00 11/03/2022
FII CX RBRAV RENDIMENTO
100 51,00 0,00 51,00 12/04/2022
FII CX RBRAV RENDIMENTO
100 53,00 0,00 53,00 11/05/2022
FII CX RBRAV RENDIMENTO
100 55,00 0,00 55,00 10/06/2022
FII CX RBRAV RENDIMENTO
100 64,00 0,00 64,00 12/07/2022
FII CX RBRAV RENDIMENTO
100 55,00 0,00 55,00 10/08/2022
FII CX RBRAV RENDIMENTO
100 55,00 0,00 55,00 13/09/2022
FII CX RBRAV RENDIMENTO
100 55,00 0,00 55,00 13/10/2022
FII CX RBRAV RENDIMENTO
100 55,00 0,00 55,00 11/11/2022
FII CX RBRAV RENDIMENTO
100 55,00 0,00 55,00 12/12/2022
FII CX RBRAV TOTAL
-- 655,00 0,00 655,00 --
FII GGRCOVEP RENDIMENTO
250 205,00 0,00 205,00 10/01/2022
FII GGRCOVEP RENDIMENTO
250 217,50 0,00 217,50 08/02/2022
FII GGRCOVEP RENDIMENTO
250 212,50 0,00 212,50 09/03/2022
FII GGRCOVEP RENDIMENTO
250 220,00 0,00 220,00 08/04/2022
FII GGRCOVEP RENDIMENTO
250 225,00 0,00 225,00 09/05/2022
FII GGRCOVEP RENDIMENTO
250 232,50 0,00 232,50 08/06/2022
FII GGRCOVEP RENDIMENTO
250 235,00 0,00 235,00 08/07/2022
FII GGRCOVEP RENDIMENTO
250 215,00 0,00 215,00 08/08/2022
FII GGRCOVEP RENDIMENTO
250 225,00 0,00 225,00 09/09/2022
FII GGRCOVEP RENDIMENTO
250 255,00 0,00 255,00 10/10/2022
FII GGRCOVEP RENDIMENTO
250 270,00 0,00 270,00 09/11/2022
FII GGRCOVEP RENDIMENTO
250 255,00 0,00 255,00 08/12/2022
FII GGRCOVEP TOTAL
-- 2.767,50 0,00 2.767,50 --
FII HECTARE RENDIMENTO
30 52,50 0,00 52,50 13/05/2022
FII HECTARE RENDIMENTO
30 53,10 0,00 53,10 14/06/2022
FII HECTARE RENDIMENTO
30 45,00 0,00 45,00 14/07/2022
FII HECTARE RENDIMENTO
30 37,50 0,00 37,50 12/08/2022
FII HECTARE RENDIMENTO
30 33,00 0,00 33,00 15/09/2022
FII HECTARE RENDIMENTO
30 33,00 0,00 33,00 17/10/2022
FII HECTARE RENDIMENTO
30 33,00 0,00 33,00 16/11/2022
FII HECTARE RENDIMENTO
30 33,00 0,00 33,00 14/12/2022
FII HECTARE TOTAL
-- 320,10 0,00 320,10 --
FII HEDGEBS RENDIMENTO
62 68,20 0,00 68,20 14/01/2022
FII HEDGEBS RENDIMENTO
62 71,30 0,00 71,30 14/02/2022
FII HEDGEBS RENDIMENTO
62 71,30 0,00 71,30 15/03/2022
FII HEDGEBS RENDIMENTO
62 71,30 0,00 71,30 14/04/2022
FII HEDGEBS RENDIMENTO
62 74,40 0,00 74,40 13/05/2022
FII HEDGEBS RENDIMENTO
62 77,50 0,00 77,50 14/06/2022
FII HEDGEBS RENDIMENTO
62 86,80 0,00 86,80 14/07/2022
FII HEDGEBS RENDIMENTO
62 80,60 0,00 80,60 12/08/2022
FII HEDGEBS RENDIMENTO
62 80,60 0,00 80,60 15/09/2022
FII HEDGEBS RENDIMENTO
62 83,70 0,00 83,70 17/10/2022
FII HEDGEBS RENDIMENTO
62 83,70 0,00 83,70 16/11/2022
FII HEDGEBS RENDIMENTO
62 86,80 0,00 86,80 14/12/2022
FII HEDGEBS TOTAL
-- 936,20 0,00 936,20 --
FII HG REAL RENDIMENTO
80 220,00 0,00 220,00 14/01/2022
FII HG REAL RENDIMENTO
80 55,20 0,00 55,20 14/02/2022
FII HG REAL RENDIMENTO
80 55,20 0,00 55,20 15/03/2022
FII HG REAL RENDIMENTO
80 55,20 0,00 55,20 14/04/2022
FII HG REAL RENDIMENTO
80 62,40 0,00 62,40 13/05/2022
FII HG REAL RENDIMENTO
80 62,40 0,00 62,40 14/06/2022
FII HG REAL RENDIMENTO
80 62,40 0,00 62,40 14/07/2022
FII HG REAL RENDIMENTO
80 62,40 0,00 62,40 12/08/2022
FII HG REAL RENDIMENTO
80 62,40 0,00 62,40 15/09/2022
FII HG REAL RENDIMENTO
80 62,40 0,00 62,40 17/10/2022
FII HG REAL RENDIMENTO
80 62,40 0,00 62,40 16/11/2022
FII HG REAL RENDIMENTO
80 62,40 0,00 62,40 14/12/2022
FII HG REAL TOTAL
-- 884,80 0,00 884,80 --
FII HTOPFOF3 RENDIMENTO
205 123,00 0,00 123,00 14/01/2022
FII HTOPFOF3 RENDIMENTO
205 123,00 0,00 123,00 14/02/2022
FII HTOPFOF3 RENDIMENTO
205 123,00 0,00 123,00 15/03/2022
FII HTOPFOF3 RENDIMENTO
205 123,00 0,00 123,00 14/04/2022
FII HTOPFOF3 RENDIMENTO
205 123,00 0,00 123,00 13/05/2022
FII HTOPFOF3 RENDIMENTO
205 123,00 0,00 123,00 14/06/2022
FII HTOPFOF3 RENDIMENTO
205 123,00 0,00 123,00 14/07/2022
FII HTOPFOF3 RENDIMENTO
205 127,10 0,00 127,10 12/08/2022
FII HTOPFOF3 RENDIMENTO
205 127,10 0,00 127,10 15/09/2022
FII HTOPFOF3 RENDIMENTO
205 127,10 0,00 127,10 17/10/2022
FII HTOPFOF3 RENDIMENTO
205 127,10 0,00 127,10 16/11/2022
FII HTOPFOF3 RENDIMENTO
205 127,10 0,00 127,10 14/12/2022
FII HTOPFOF3 TOTAL
-- 1.496,50 0,00 1.496,50 --
FII JS REAL RENDIMENTO
100 53,00 0,00 53,00 21/01/2022
FII JS REAL RENDIMENTO
100 53,00 0,00 53,00 21/02/2022
FII JS REAL RENDIMENTO
100 53,00 0,00 53,00 22/03/2022
FII JS REAL RENDIMENTO
100 48,90 0,00 48,90 25/04/2022
FII JS REAL RENDIMENTO
100 49,00 0,00 49,00 20/05/2022
FII JS REAL RENDIMENTO
100 49,00 0,00 49,00 22/06/2022
FII JS REAL RENDIMENTO
100 49,00 0,00 49,00 14/07/2022
FII JS REAL RENDIMENTO
100 49,00 0,00 49,00 12/08/2022
FII JS REAL RENDIMENTO
100 49,00 0,00 49,00 15/09/2022
FII JS REAL RENDIMENTO
100 49,00 0,00 49,00 17/10/2022
FII JS REAL RENDIMENTO
100 49,00 0,00 49,00 16/11/2022
FII JS REAL RENDIMENTO
100 49,00 0,00 49,00 14/12/2022
FII JS REAL TOTAL
-- 599,90 0,00 599,90 --
FII KINEA SC RENDIMENTO
100 145,00 0,00 145,00 13/01/2022
FII KINEA SC RENDIMENTO
200 250,00 0,00 250,00 11/02/2022
FII KINEA SC RENDIMENTO
200 200,00 0,00 200,00 14/03/2022
FII KINEA SC RENDIMENTO
200 224,00 0,00 224,00 13/04/2022
FII KINEA SC RENDIMENTO
200 228,00 0,00 228,00 12/05/2022
FII KINEA SC RENDIMENTO
200 270,00 0,00 270,00 13/06/2022
FII KINEA SC RENDIMENTO
200 218,00 0,00 218,00 13/07/2022
FII KINEA SC RENDIMENTO
200 182,00 0,00 182,00 11/08/2022
FII KINEA SC RENDIMENTO
200 140,00 0,00 140,00 14/09/2022
FII KINEA SC RENDIMENTO
200 100,00 0,00 100,00 14/10/2022
FII KINEA SC RENDIMENTO
200 104,00 0,00 104,00 14/11/2022
FII KINEA SC RENDIMENTO
200 150,00 0,00 150,00 13/12/2022
FII KINEA SC TOTAL
-- 2.211,00 0,00 2.211,00 --
FII RBR PCRI RENDIMENTO
20 27,00 0,00 27,00 16/08/2022
FII RBR PCRI RENDIMENTO
20 24,00 0,00 24,00 19/09/2022
FII RBR PCRI RENDIMENTO
20 20,00 0,00 20,00 19/10/2022
FII RBR PCRI RENDIMENTO
20 20,00 0,00 20,00 18/11/2022
FII RBR PCRI RENDIMENTO
20 20,00 0,00 20,00 16/12/2022
FII RBR PCRI TOTAL
-- 111,00 0,00 111,00 --
FII RBRALPHA RENDIMENTO
162 98,17 0,00 98,17 18/01/2022
FII RBRALPHA RENDIMENTO
162 97,20 0,00 97,20 16/02/2022
FII RBRALPHA RENDIMENTO
162 97,20 0,00 97,20 17/03/2022
FII RBRALPHA RENDIMENTO
162 97,20 0,00 97,20 19/04/2022
FII RBRALPHA RENDIMENTO
162 97,20 0,00 97,20 17/05/2022
FII RBRALPHA RENDIMENTO
162 97,20 0,00 97,20 17/06/2022
FII RBRALPHA RENDIMENTO
162 115,02 0,00 115,02 18/07/2022
FII RBRALPHA RENDIMENTO
162 97,20 0,00 97,20 16/08/2022
FII RBRALPHA RENDIMENTO
162 97,20 0,00 97,20 19/09/2022
FII RBRALPHA RENDIMENTO
162 102,06 0,00 102,06 19/10/2022
FII RBRALPHA RENDIMENTO
162 102,06 0,00 102,06 18/11/2022
FII RBRALPHA RENDIMENTO
162 102,06 0,00 102,06 16/12/2022
FII RBRALPHA TOTAL
-- 1.199,77 0,00 1.199,77 --
FII RBRHGRAD RENDIMENTO
105 112,35 0,00 112,35 18/01/2022
FII RBRHGRAD RENDIMENTO
105 115,50 0,00 115,50 14/02/2022
FII RBRHGRAD RENDIMENTO
105 115,50 0,00 115,50 17/03/2022
FII RBRHGRAD RENDIMENTO
105 126,00 0,00 126,00 19/04/2022
FII RBRHGRAD RENDIMENTO
105 126,00 0,00 126,00 17/05/2022
FII RBRHGRAD RENDIMENTO
105 126,00 0,00 126,00 17/06/2022
FII RBRHGRAD RENDIMENTO
105 132,93 0,00 132,93 18/07/2022
FII RBRHGRAD RENDIMENTO
105 115,50 0,00 115,50 12/08/2022
FII RBRHGRAD RENDIMENTO
105 105,00 0,00 105,00 19/09/2022
FII RBRHGRAD RENDIMENTO
105 73,50 0,00 73,50 19/10/2022
FII RBRHGRAD RENDIMENTO
105 73,50 0,00 73,50 18/11/2022
FII RBRHGRAD RENDIMENTO
105 73,50 0,00 73,50 16/12/2022
FII RBRHGRAD TOTAL
-- 1.295,28 0,00 1.295,28 --
FII REC RECE RENDIMENTO
364 529,91 0,00 529,91 14/01/2022
FII REC RECE RENDIMENTO
364 382,20 0,00 382,20 14/02/2022
FII REC RECE RENDIMENTO
364 435,38 0,00 435,38 15/03/2022
FII REC RECE RENDIMENTO
364 497,95 0,00 497,95 14/04/2022
FII REC RECE SUBSCRICAO
38 0,00 0,00 0,00 29/04/2022
FII REC RECE RENDIMENTO
364 546,87 0,00 546,87 13/05/2022
FII REC RECE RENDIMENTO
38 65,37 0,00 65,37 14/06/2022
FII REC RECE RENDIMENTO
364 626,26 0,00 626,26 14/06/2022
FII REC RECE RENDIMENTO
402 462,30 0,00 462,30 14/07/2022
FII REC RECE RENDIMENTO
402 410,24 0,00 410,24 12/08/2022
FII REC RECE RENDIMENTO
402 321,60 0,00 321,60 15/09/2022
FII REC RECE RENDIMENTO
402 241,20 0,00 241,20 17/10/2022
FII REC RECE RENDIMENTO
402 177,80 0,00 177,80 16/11/2022
FII REC RECE RENDIMENTO
402 295,47 0,00 295,47 14/12/2022
FII REC RECE TOTAL
-- 4.992,55 0,00 4.992,55 --
FII VINCI SC RENDIMENTO
213 172,53 0,00 172,53 14/01/2022
FII VINCI SC RENDIMENTO
213 144,84 0,00 144,84 14/02/2022
FII VINCI SC RENDIMENTO
213 144,84 0,00 144,84 15/03/2022
FII VINCI SC RENDIMENTO
213 144,84 0,00 144,84 14/04/2022
FII VINCI SC RENDIMENTO
213 149,10 0,00 149,10 13/05/2022
FII VINCI SC RENDIMENTO
213 149,10 0,00 149,10 14/06/2022
FII VINCI SC RENDIMENTO
213 149,10 0,00 149,10 14/07/2022
FII VINCI SC RENDIMENTO
213 151,23 0,00 151,23 12/08/2022
FII VINCI SC RENDIMENTO
213 153,36 0,00 153,36 15/09/2022
FII VINCI SC RENDIMENTO
213 157,62 0,00 157,62 17/10/2022
FII VINCI SC RENDIMENTO
213 159,75 0,00 159,75 16/11/2022
FII VINCI SC RENDIMENTO
213 161,88 0,00 161,88 14/12/2022
FII VINCI SC TOTAL
-- 1.838,19 0,00 1.838,19 --
HYPERA JCP
200 61,76 9,26 52,50 07/01/2022
HYPERA JCP
200 61,63 9,24 52,39 07/01/2022
HYPERA JCP
200 61,61 9,24 52,37 07/01/2022
HYPERA JCP
200 61,76 9,26 52,50 07/01/2022
HYPERA TOTAL
-- 246,76 37,00 209,76 --
ITAUSA JCP
1.000 23,52 3,52 20,00 03/01/2022
ITAUSA JCP
1.000 154,72 23,20 131,52 11/03/2022
ITAUSA TOTAL
-- 178,24 26,72 151,52 --
MAGAZ LUIZA JCP
800 12,39 1,85 10,54 06/05/2022
MAGAZ LUIZA TOTAL
-- 12,39 1,85 10,54 --
MITRE REALTY DIVIDENDO
400 40,31 0,00 40,31 16/03/2022
MITRE REALTY DIVIDENDO
400 26,60 0,00 26,60 27/05/2022
MITRE REALTY DIVIDENDO
400 17,04 0,00 17,04 28/09/2022
MITRE REALTY DIVIDENDO
400 47,00 0,00 47,00 28/11/2022
MITRE REALTY TOTAL
-- 130,95 0,00 130,95 --
PETROBRAS DIVIDENDO
100 293,88 0,00 293,88 31/08/2022
PETROBRAS JCP
100 42,71 6,40 36,31 31/08/2022
PETROBRAS DIVIDENDO
100 336,60 0,00 336,60 20/09/2022
PETROBRAS DIVIDENDO
100 115,58 0,00 115,58 20/12/2022
PETROBRAS JCP
100 51,86 7,77 44,09 20/12/2022
PETROBRAS TOTAL
-- 840,63 14,17 826,46 --
QUALICORP DIVIDENDO
400 102,17 0,00 102,17 12/12/2022
QUALICORP TOTAL
-- 102,17 0,00 102,17 --
RAIZEN JCP
271 4,40 0,66 3,74 25/03/2022
RAIZEN JCP
271 5,96 0,89 5,07 25/03/2022
RAIZEN JCP
271 7,52 1,12 6,40 27/04/2022
RAIZEN DIVIDENDO
271 8,56 0,00 8,56 13/10/2022
RAIZEN TOTAL
-- 26,44 2,67 23,77 --
SANEPAR JCP
1.800 185,57 27,83 157,74 24/06/2022
SANEPAR JCP
1.800 214,68 32,20 182,48 24/06/2022
SANEPAR TOTAL
-- 400,25 60,03 340,22 --
SIMPAR JCP
800 84,09 12,61 71,48 31/01/2022
SIMPAR DIVIDENDO
800 412,49 0,00 412,49 18/05/2022
SIMPAR TOTAL
-- 496,58 12,61 483,97 --
SLC AGRICOLA DIVIDENDO
220 533,75 0,00 533,75 18/05/2022
SLC AGRICOLA TOTAL
-- 533,75 0,00 533,75 --
TRAN PAULIST JCP
400 69,55 10,43 59,12 18/01/2022
TRAN PAULIST TOTAL
-- 69,55 10,43 59,12 --
YDUQS PART DIVIDENDO
200 25,29 0,00 25,29 06/12/2022
YDUQS PART TOTAL
-- 25,29 0,00 25,29 --
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}