using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[㠯㵎㼝䠶䰾䳘丟並亂亙亞亾佀佇佈佔併來侖侶侷俁係俠俲俻倀倆倉個們倖倫偉偪側偵偽傌傑傖傘-傚傭傯傳-債傷傾僂僅僉僑僕僞僥僨僱價儀儂億儈儉儐儔儕儗儘償優儲儷儸儺-儼兇兌兒兗內兩冊冪凈凍凜凱別-刧刪刼剄則剉剋剎剛剝剮剴創剷劃劄劇劉劊劌劍劑効勁動務勛勝勞勢勣勦勱-勳勵勸勻匭匯匱區協卹卻厙厠厭厲厴參叢吳吶呂咷咼員哶唄唚問啞啟啣喚喪-喬單喲嗆嗇嗎嗚嗩嗶嘆嘊嘍嘓嘔嘖嘗嘜嘩嘮-嘰嘵嘷嘸嘽噁噓噝噠噥噦噯噲噴噸噹嚀嚇嚌嚐嚕嚙嚥嚦嚨嚲-嚴嚶囀-囂囅囈囉囌囑囪圇國圍園圓圖團埡執堅堊堖堝堯報場塊塋塏塒塗塚塢塤塲塵塹墊墜墮墳墻墾壇壓壘-壚壞-壠壢壩壯壺壼壽夠夢夾奐奧奩奪奮奼妝姍姦姪娛婁婦婭媧媯媼媽嫋嫗嫵嫻嬀嬈嬋嬌嬙嬝嬡嬤嬪嬰嬸孃孌孫學孿宂宮寢實寧審寫寬寳寵寶將專尋對導尒尷屆屍屓屜屢層屨屬屭岡峩峯峴島峽崍崐崑崗崙崢崬嵐嵗嶁嶃嶄嶇嶔嶗嶠嶧嶴嶸嶺嶼嶽巋巒巔巖巹帥師帬帳帶幀幃幇幗幘幚幟幣幫幬幹幾庫廁廂廄廈廕廚廝廟-廣廩廬廳廹弒弔弳張強彆彈彊彌彎彙彞彠彥彫彿後徑從徠復徹怳恆恥悅悳悵悶悽惡惥惪惱惲惷惻愙愛愜愨愴愷愾慂慄態慍慘慚慟慣慪慫慮慳慶慼慾憂憊憐-憒憚憤憫憮憲憶懇應懌懍懟懣懨懲懶-懸懺懼懾戀戇戔戞戧戩戰戲戶戼抝拋挾捨捫捲掃掄掙掛採揀揚換揮揹損搖搗搯搵搶摑摜摟摯摳摶摻撈撏撐撓撝撟撣撥撧撫撲撳撻撾撿擁擄擇擊擋擔據擠擬擯-擲擴擷擺-擼擾攄攆攏攔攖攙攛-攝攢-攤攪攬敍敗敘敱敵數斂斃斕斬斷旂旹昰時晉晝暈暉暘暢暫暱曄曆曇曉曖曠曡曨曬書會朧朶東柵栢桮桿梔梘條梟棄棖棗棟棧棲椀椏楄楊楓楨業楳極榪榮榿構槍槓槤槧槨槮槳樁樂樅樓標樞樣樸-樺橈橋機橢橫檁檉檔檜檟檢檣檮檯檳檸檻櫂櫃櫓櫚櫛櫝-櫟櫥櫧櫨櫪-櫬櫱櫳櫸櫺櫻欄權欏欒欖欞欽歎歐歟歡歲歷歸歿殀殘殞殤殫殭-殯殲殺殼殽毀毆毿氂氈氌氣氫氬氳氷決沒沖況洶浹涇涖涼淒淚淥淨淪淵淶淺渙減渦測渾湊湞湧湯湼溈準溝溫滄滅滌滎滙滬滯滲滷滸滻滾滿漁漚漢漣漬漲漵漸漿潁潑潔潛潤潯潰潷潿澀澆澇澗澠澤澮澱濁濃濕濘濛濟濤濫濬濰濱濺濼濾瀅瀆瀉瀋瀏瀕瀘瀝瀟瀠瀦-瀨瀰瀲瀾灃灄灑灕灘灝灣灤灩災為烏烴無煉煒煗煙煢煥煩煬熒熗熱熲熾燁燈燉燒燙燜營燦燬燭燴燼燾爍爐爛爭爲爺爾牆牎牕牘牽犖犢犧狀狹狽猙猶猻獁獄獅獎獘獨獪獫獮獰獲獵獷獸獺-獼玀玨珮現琊琹琺琿瑋瑣瑤瑩瑪瑯璉璣璦環璵璽瓊瓏瓔瓚甌甕產甦甯畝畢畫畬異當疇疉疊痙痺痾瘂瘋瘍瘓瘞瘡瘧瘮瘲瘻療癆癇癉癒癘癟癡癢癤癥癧癩癬-癮癰-癲發皐皚皰皸皺盃盌盜盞盡監盤盧盪眥眾睏睜睞睺瞇瞘瞜瞞瞼矇矓矚矯砲硃硤硨硯碩碭碸確碼磑磚磣磧磯磽礄礆礎礙礡礦礪-礬礱祿禍禎禑禕禡禦禪禮禰禱禿秌稅稈稜稟稭種稱稾穀穌-穎穠-穢穩穫窓窩窪窮-窰窶窺窻竄竅竇竊竝竪競筆筍筧筩筯箇箋箏節範築篋篔篤篩篳簀簍簞簡簣簫簷簹簽簾籃籌籐籖籙籛籜籟籠籤籩籪籬籮籲粃粵粺糝糞糧糭糰糲糴糶糾紀紂約-紉紋納紐紓-紕紗-紝紡紥紮細-紳紵紹紺紼紿絀終組絆絎結絕絛絝絞絡絢給絨統-絳絶絹綁綃綆綈綉綏綑經綜綠綢綣綫-維綰-網綴綵綸-綻綽-綿緄緇緊緋緒緔緗-線緜-緞締緡緣緥緦編緩緬緯緱緲練緶緹緻縈-縋縐縑縗縛縝-縟縣縧縫縭縮縱縲縴-縷縹總績繃繅繆繒織繕繚繞繡繢繩-繫繭-繰繳繹繼-繾纈-纊續纍纏纓纔纖纘纜缽罈罌罰罵罷羅羆羈羋羗羥羨義翄習翬翹翺耑耬聖聞聯聰聲聳聵-職聹聽聾肅肈脅脈脛脫脹腎腖腡腦腫腳腸膃膆膕膚膠膩膽-膿臉臍臏臕臘臚臟臠臢臥臨臺與-舊舖舘艙艤艦艫艱艶艷芻苧茲荊荳莊莖莢莧菕華萇萊萬萵萹葉葒葦葯葷蒓蒔蒞蒼蓀蓋蓮蓯蓴蓽蔔蔞蔣蔥蔦蔭蔴蕁蕆蕎蕒蕓蕕蕘蕢蕩蕪蕭蕷薈薊薌薑薔薙薦薩薺藍藎藝藥藪藶藹藺蘄蘆蘇蘊蘋蘚蘞蘢蘭蘺蘿處虛虜號虧虯虵蛺蛻蜆蝕蝟蝦蝨蝯蝱蝸螄螞螢螮螻螿蟄蟈蟎蟣蟬蟯蟲蟶蟻蠅蠆蠍蠐蠑蠔蠟蠣蠨蠭蠱蠶蠻衂衆衊術衕衚衛衝袞裊裌裏補裝裡製複褌褘褭褲褳褸褻襃襇襖襝襠襤襪襯襲襴覇覈見規覓視覘覡覥覦親覬覯覲覷覺覽覿觀觴觶觸訂訃計訊訌討訐訓訕-記訛訝訟訢訣訥訪設許訴訶診-証詁詆詎詐詒詔-詖詘詛詞詠-詣試詧詩詫-詮詰-詳詵詼詿誄-誇誌認誑誒誕誖誘誚語誠誡誣-誦誨說誰課誶誹誼誾調諂諄談諉請諍諏諑諒論諗諛諜諞諠-諢諤諦諧諫諭諮諱諳諶-諸諺諼諾謀-謂謄謅謊謌謎謐謔謖謗謙-講謝謠謨謫謬謳謹謾譁證譌譎譏譔譖識-譚譜譟譫譭譯議譴護譽譾讀變-讌讎讒讓讕讖讚讜讞谿豈豎豐豬貍貎貓貙貝貞負-貢貧-責貯貰貲-貴貶-貸貺-貽貿-賅資賈賊賑-賓賕賙賚賜賞賠-賤賦賧質-賭賴賺-賾贄贅贇贈贊贍贏贐贓贔贖贗贛趕趙趨趲跡踐踰踴蹌蹕蹟蹣蹤蹺躂躉-躋躍躑-躓躕躚躛躡躥躦躪躳軀車-軍軒軔軛軟軫軲軸-軼軾較輅輇載輊輒-輕輙輛-輟輥輦輩輪輯輳輸輻輾-轀轂轄-轆轉轍轎轔轟轡轢轤辠辢辤辦辭-辯農迴逕這連週進遉-運過達違遙遜遞遠適遲遶-選遺遼邁還邇邊邏邐郟郵鄆鄉鄒鄔鄖鄧鄭鄰鄲鄴鄶鄺酈醃醜醞醫醬醱釀釁釃釅釋釐釓-釕釗-釙針釣釤釦釧釩釵釷釹釺鈀鈁鈄鈈鈉鈍鈎鈐鈑鈔鈕鈞鈣鈥-鈧鈮鈰鈳鈴鈷-鈺鈽-鉀鉅鉈鉉鉋鉍鉑鉕鉗鉚鉛鉞鉢鉤鉦鉬鉭鉸鉺鉻鉿銀銃銅銑銓銖銘銚-銜銠銣銥銦銨-銬銲銳銷銹銻銼銾鋁鋃鋅鋇鋌鋏鋒鋝鋟鋤-鋦鋨-鋪鋮-鋱鋸鋻鋼錁錄錆-錈錏錐錒錕錘-錛錟-錢錦錨錫錮錯錳錶錸鍀鍁鍆鍇鍊鍋鍍鍔鍘鍛鍠鍤鍥鍩鍬鍰鍵鍶鍺鍼鍾鎂鎄鎇鎊鎔鎖鎘鎛鎡-鎣鎦鎧鎩鎪鎬鎮鎰鎳鎵鎿鏃鏇鏈鏌鏐鏑鏗鏘鏜-鏟鏡鏢鏤鏨鏰鏵鏷鏹鐃鐐鐒-鐔鐘鐙鐝鐠鐦-鐨鐫鐮鐲鐳鐵鐸鐺鐿鑄鑊鑌鑑鑒鑔鑞鑠鑣鑥鑭鑰鑲鑷鑼-鑿钁長門閂閃閆閈閉開閌閎閏閑間閔閘閡閣閥閧-閩閫-閭閱閶閹閻-閿闃闆-闈闊-闍闐闓-闖關闞闡闢闥陘陝陞陣陰陳陸陽隂隄隉隊階隕際隨險隱隴隸隻雋雖雙雛雜雞離難雲電霑霧霽靂靄靆靈靉靚靜靦靨鞌鞏鞦韁韃韆韉韋韌韓韙韜韞韮韻響頁-頃項-須頊頌頎-頓頗領頜頡頤頦頭頰頴頷-頹頻顆顇題-顏顒-顔願顙顛類顢顥顧顫顬顯-顱顳顴風颭-颯颱颳颶颺-颼飄飆飈飛飜飢飤飩-飫飭飯飱飲飴飼-飾餃-餅餉養餌餎餑-餕餘餛餜餞餡館餬餱餳餵餺-餿饁饃饅饈-饍饑饒饗饜饞饢馬-馮馱馳馴駁駐-駒駔駕駘駙駛駝駟駡駢駭駮駰駱駸駿騁騅騍-騏騖騙騫騭騮騰騶-騸騾驀-驅驊驍驏驕驗驚驛驟驢驤驥驪骯髈髏髐髒體-髖髮鬆鬍鬚鬢鬥鬧-鬪鬭鬮鬱魎魘魚魯魴魷鮁鮃鮌-鮎鮐-鮒鮚鮞鮪鮫鮭鮮鯀鯁鯇鯉鯊鯔鯖鯗鯛鯡鯢鯤鯧鯨鯪鯫鯰鯷鯽鯿鰂鰆鰈鰉鰍鰐鰒鰓鰟鰣鰥鰨鰩鰭鰮鰱-鰳鰷鰹鰻鰾鱅鱈鱉鱒-鱔鱖-鱘鱝鱟鱣鱧鱭鱷鱸鱺鳥鳧鳩鳳鳴鳶鴆鴇鴉鴒鴕鴛鴝-鴟鴣鴦鴨鴯鴰鴴鴻鴿鵂鵑-鵓鵜-鵞鵠鵡鵪鵬鵯鵰鵲鵾鶇鶉鶓鶖鶘鶚鶩鶯鶲鶴鶺-鶼鷀鷂鷈鷉鷓鷖鷗鷙鷥鷦鷯鷲-鷴鷸-鷺鷽鷿鸊鸕鸚鸛鸝鸞鹵鹹鹺鹼鹽麗麥麩麪麵麼黃黌點黨黲黴黷黽黿鼉鼕鼴齊齋齎齏齒齔齙齜齟-齡齣齦齪齬齲齶齷龍龎龐龔龕龜]";
string input = @"Online regex tester, debugger with highlighting for PHP, PCRE, Python, Golang and JavaScript.
You've visited this page 2 times. Last visit: 21/08/20
People also search for
regex tutorial
regex c#
regex python
regex cheat sheet
This free regular expression tester lets you test your regular expressions against any entry of your choice and clearly highlights all matches. It is JavaScript based ...
测试测试测试测试
1.5 新闻动态
阿列克謝·納瓦爾尼
俄羅斯反對派反对派領袖阿列克謝·納瓦爾尼(圖)在從托木斯克返回莫斯科途中感到不適,其後被送到鄂木斯克醫院急救。
全球各地在2019冠状病毒病疫情期間的累計確診人數突破2,200萬人,並造成至少78.1萬人死亡。
美國民主黨全國代表大會正式提名前副總統乔·拜登為民主黨在總統選舉的候選人。
马里武裝部隊在首都巴馬科發動軍事政變,其後總統易卜拉欣·凱塔宣布辭職、解散政府和國民議會。
英國台球選手罗尼·奥沙利文以18比8擊敗奇倫·威爾森,贏得2020年世界斯诺克锦标赛冠軍。
最近逝世:斯雷德·戈登-鮑里斯·巴頓-馬達夫·普拉薩德·吉米瑞-切薩萊·羅米蒂-本·克羅斯
文化審議会は2010年6月7日、改定常用漢字表(2136字/4388音訓[2352音・2036訓])を答申した。これは同年11月30日に平成22年内閣告示第2号「常用漢字表」として内閣告示された。その際、昭和56年内閣告示第1号「常用漢字表」は廃止された。";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}