import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[㐄-㐆㐌㐖㐜㐡㐤㐰㐺㑇㑩㑳㒳㒸㔾㗂㗎㝉㝵㞎㞙㞞㢲㢴㤅㥁㥯㧑㨗㫺㬎㮎㮚㮸㲋㲱㲾㳮㵪㶸㷖㷭㹢㹴㺢㺵㽮㿝䁖䌽䍃䔢䖟䖸䗈䗖䗥䗪䜣䜩䝓䝙䥯䦉䯝䲔䲠䳗䴘䴙䵹䶑一-丞丠-严丧-丮丰-乀乂-乫乭买乱乳-乺乼乾-亁亃-争事-亖亘亚-亜亟亡亢交-亮亲亳亵亶亸-亽亿-介仍-仏仑-仚仝-仟仡代-以仨仪-们仮仰仲仳仵-价任份仿-企伄伈-伋伍-休伕众-传伢伤-伧伪伫伯-伲伴伶伸-伾佃但佉佌-佑体何佗-佥佧佩-佬佯-佱佳佴佶-侅侇-侉例-侍侏-侑侔侗侘侚-依侠価侣侥-侪侬侮侯侵便促-俅俉俊俎-俑俓俔俗俘俚-俟信俣俦俨-俪俭-俯俱俳-俸俺俾倂倅倌倍倏倒-倔倘-倚倜倝借倡-倦倨-倪倬-倮倶倷倹-值倾偁偃假偈偌偎偏偓偕做停偝偟偢健偨偩偫-偭偯-偲偶-偸偺偻偾-傀傅傈傍傎傒傔傕傜傞傢傣傥傧-傩催傮傲傺傻傿僄僇僊働-像僔僖僚僝僣僤僦僧僩僬-僰僳僵僻僾僿儁儃儅-儇儊-儍儒儓儜儞儡儤儦儩儭儱儳儵儹儽儿-允元-兆先光克免兎児兑兔-兖兙-兟兡-兣入全兪-兮兰-兹养-兽冀-冃内-冉册再冏冑-写军农冞冠冢冤冥冫冬冯-决况-冷冻-冽净凃-凇凉-凌减凑凔凛凝凞几-凢凤処凫凭凯凰凳凵凶凸-函凿-刃分-刈刊刍刎刑-刓刖-初删刡判刨利别刭刮到-刻刽刿-剃削剌前剐-剒剔-剖剚剜剞剟剡剣-剥剧剩剪副剰割剸剺剽剿劁劂劈劒劓劖劘劙力劝-劣劦动-劭励-劵劻劼劾势勃勅勇勉勋勍勐勒勖-勘募勤勧勩勯勰勷勹勺勾-匁包匆匈-匋匍匏匐匕-北匙匚匜匝匟-匡匣匦匪匮匸-医匽-匿十-卓单-単博-卤卦-卨卪-卬卮-卵卷卸卺卼卽卿厂厄-历厉压-厎厐厓-厘厚厜厝原厢-厦厨-厪厮厰厳厹-厼厾县叁参叄叆-収发叔取-叛叟-叡口-另叨-右叵-叹叻-叽吁吃-吆合-吗君-吡吣否-吲吴吵吸吹吻-吾呀呃呆-呋呎-呐呒-呙呛呜呠-呤呦-周呪-呬呯-呸呺-命呿-咂咄咆-咈咋-咒咔-咗咙-咛咝咠-咯咱-咴咸-咻咽-哂哄哆-哉哋-哕哗哙哚哜-哟哢哤-哫哭哮哰-哳哺哼哽哿唁唅-唉唎-唑唔唕唛唞唠唢-唤唧唪唬售-唳唵-唹唻唼唾-啁啃-商啉啊啍啎啐啓啕-啗啜啡啢啤-啧啪-啲啴-啸啺-啾喀-善喆-喌喎喏喑-喔喘喙喜喝喟喣-喩喭喱喳喵-喷喹-嗀嗃-嗅嗈-嗊嗍嗐-嗖嗙嗛-嗝嗟嗡嗣-嗦嗨嗪-嗬嗯嗰嗲嗳嗵嗷嗹嗽-嘂嘅嘈嘉嘌嘎-嘐嘒嘘嘚嘛嘞嘟嘢-嘧嘬嘭嘱嘲嘴嘶嘹嘻嘿噀噂噅噇噉噌-噏噔噗-噚噜噞噢噤器-噭噱噳噶噷噻噼嚃-嚆嚎嚏嚓嚔嚚嚜嚞嚟嚣嚬-嚯嚵嚷嚼囊囍囒-囔囗囘囚四囝-囥囧囨囫-囻国-圀圂-圄圆圈-圊圌圏圕圛圜圞土圣圧-圪圬-地圳圴圹-圻圾址坂坆均坊-坓块坚-坡坤坦坨-坫坭坯-坱坳-坵坷坻坼垂-垆垈型-垍垒-垕垗垚垛垝-垠垢-垤垦垧垩垫垭-垯垲垴垵垺垾-埀埂-埄埆-埈埋埌城埏埒埔埕埗-埚埜域埠埤埦埧埭埯埰埲-埶埸-基埼埽堀堂-堄堆-堉堋-堎堑堕堙堞堠堡堤堧堨堪堭堮堰堲堳堵堽堿塁塄塈塌塍塑塓-塕塘塙塝塞塡塥塩填塬塱塼-墁境墅墈墉墐墒墓増墙墝-墠墦墨墩墫墬墰墺壁壅壆壈壊壌壎壑壒壔-壖壜壝壡壤士-壮声-壴壶壸壹壻壿夂处-备変夊夌复夏夓-多夜够夤夥大天-夯失头夶-夺夼奁奂奄奇-奉奋奌奎奏契奓-奘奚奜奠-奣奥奨奫-奭奰女奴奶奸她好妁-妄妆-妈妊妍妒妓妖妗妙妚妞妣-妥妨-妬妮妯妲妳妵妹-妻妾姁姅姆姉-始姐-委姗-姚姜-姞姣-姥姧姨姫姬姮姱姸-姻姽姿-威娃-娉娌娑娓娘娜娟娠娣娥娩娭娯娱娲娴-娶娸娼婀婆婉婊婐婕婚婞婢婤婥婧婪婬婴-婷婹婺婼婽婿媁媄媊媒媕媚媛媞-媠媢媪媬媮媲媳媵媸媺媻媾媿嫁嫂嫄嫈嫉嫌嫏嫒嫔-嫖嫘嫚嫜嫠嫡嫣嫦嫩-嫬嫰嫱嫺嫽嫿嬃嬅嬉嬔嬖嬗嬛嬢嬦嬬嬭嬲嬴嬷嬹嬾-孀孅孏-孑孓-孝孟孢-学孩孪孬孭孰孱孳孵孺孻孽宀宁它-宅宇-宍宏宓宕宗-宨宪-宬宰害-家宸容宽-寇富寎寐寒-寔寖寘寙寛寝-寡寤寥寨寪寮寰寸-导対寿封-将尉尊尌小少尓-尚尜尝尟尢尤尥尧尨尪尬尭尰-尲尴尶尸-居屇-屌屎-屑展屖屘屙屛屝属屠屡屣履-屧屩屪屮屯山屴屹屺屼屿-岂岊岌岍岐-岒岔岖-岛岝岢岣岧-岩岫-岭岱岳岵岷岸岽岿峁峄峇峋峒峓峙峞峠峡峤-峦峨峪峭峰峱峹峻峿-崃崆崇崋崌崎崒崔崖崚崛崞-崠崤崦崧崩崭崮崱崳崴崶崽崿嵂嵇嵊-嵌嵎嵒嵓嵘-嵛嵝嵞嵡嵩嵫嵬嵯嵴嵼嵾嶂嶋嶌嶒嶓嶙嶝嶞嶡嶢嶨嶭嶮嶰嶲嶷巂巃巅-巇巉巌巍巓巘巛川-巩巫差巰-巴巷巻巽-巿币-布帅帆师希帏-帑帔-帝帟帡帣带-帨席-帱帷-帹帻-帽幂幄幅幋幌幏幔幕幙幛幞幠-幢幦幨-幪幭幯幰干-幸幺-幽广-庁広庄庆-庋序-庑库-店庙庚府庞-庠庤-座庬庭庱庳-庹庾庿廃廆廉-廌廎-廓廖廛廞廥廧廨廪廱延-廸建-廼廾-弄弇弈弊-弑弓引弗弘弛弝弟张弢-弪弭-弱弶弸-强弼弾彀彄归-彘彝彟形彤彦彧彩彪彬彭彰-彴彷-役彻-彽往-徂径待徇-律徐徒従徕得-徙徜御徨循徬-徯徳-徵德徻-徽忀心必忆忉忌忍忏-忒忖-忙応-忞忠忡忤忧忪快忭忮忱念忸忻忽-怆怍-怏怒怔-怗怙-怞怠怡急-怫怭怯怱怲怵怸怹总怼怿恁-恃恇恉恋-恍恏恐恒-恕恘-恛恝-恠恢-恤恧-恭息恰恳恵恶恸-恽恿-悁悃悄悆悉悊悌悍悐悒悔悖悚-悝悟悠患悤悦-悲悴悸悻悼悾惄-惇惊-惌惎惏惑惓-惕惘-惝惟惠惦-惩惫-惰想惴惶惸-惺愀愁愃愆愈-愊愍-愕愚感愠愣愤愦愧愫愬愮愯愼愿慁慅-慊慌慎慑慕慝慢慥慧慨慬慰慱慴慵慷憀憃憋憍憎憔憖憙憝憧-憪憬憭憯憷-憺憾懂懃懅懆懈懊懋懐-懒懔懞懠懤-懦懫懮懰懱懵懽懿戁戄戆戈-戒戕-战戚戛戝戟-戦截戬-戯戱戳戴户-戻戽-扃扆-手才扎扐-払扗托扛扞扠-扤扦执扩-扱扳扶批扻-技抃抄抆抈-把抌抏抑-折抚-抜択-抢护报抨披抬抱抵抶抹抻-抽抿拂-拊拌-拔拖-拝拟-拣拥-择拫-拯拱拳拴拶拷拼-拿持挂指-按挌-挎挐挑挓挖挙-挛挝-挦挨挪挫振挲挶挹挺挽挿捂-捆捉捋-捐捕捗-捙捜捞损捡-捣捥捧捩捭据捱捶捷捺-捽掀掂掇-掊掌掎-掐排掔掖-掘掞掠探-接控-掬掮-掴掷掸掺掼-掾揃-揆揉揌-提插揕-揘揜-揞揠握揣揥揩-揫揭揰揲援-揶揸揺揽-搂搅搆搉-搌搎-搐搒-搕搘搜搞搠-搨搪搬搭搰搲-搴搷携搽-摈摊摎摒-摔摘摙摛摞摠摦摧摩摭摮摰摲摴摷-摺摽撂-撅撇撊撋撑撒撕撙撚撞撢撤撦撩撬-撮撰撱撵撷撸撺撼擀擂擅擉操擎擐擒擕-擘擞擡-擤擦-擩擫擭擸擽擿攀攃攉攐攒攓攘攥攩攫攮-攰攲攴收-改攻攽-政敁敃故敇-敉敌敎敏救敔-敖教敛-敞敢散敦敧敪敬数敲-整敷敹-敻敿斁斄文斉斋斌斎斐-斓斗料斛-斢斤斥斧-斩斫断-新斲斸方於-旁旃-旆旋旌旎-旐旒旓旖旗旛旝旟-旣日-早旬-旱旴时-旸旺-旽昀昂-昄昆昇昉昊昌明昏昑易-昕昙昜-昡昤-昨昫昭是昱昳-昶昺-显晁晃-晅晋晌晏晒-晗晚-晜晞晟晡晢晤-晦晨晩晬普-晰晴晶晷智晾晿暁暂暄暆暇暋-暍暐暑暔-暗暝暠暡暦-暨暪暮暲暴暵暸暹暻暾曀曈曌曏曐曘-曝曦曩曰-更曷曹曼-朁朅朆月-朋服朏朐朓-朕朗-朙望朝期朠朢朣朦木-朱朳-朵机朽-杀杂权杅-杉杌李-村杓杕-杗杙杜-条来杨-杪杭杯杰杲-杸杻杼松板极构枇枉枋枌析枒枓枕林-枚果-枟枢枣枥枧枨枪枫枭枯枰枲-枹枻柁-柅柈柊柎-柔柘-柚柜-柠柢-查柩柬柮-柴柶-柸柺査柽柿栀栃-栅标-栌栎栏树-栔栖-栘栝栟校栩-栫栭栱-栵样-根栻-栾桀-框案桉桋桌桎桐桑桓-桕桜桟-桩桫桭桯桲桴桶桷桹梁梃梅梆梊梍梏梐梓梗梜梠-梣梦-梩梭梯-梵梹梼梿-棃棉棋棍棐-棒棕棘棚棜棠棣棨-棬森-棱棳棵棸-棼椁椄-椆椈椊-椎椐-椓椗検椟椠椤椪椭椮椰椳-椵椷-椹椽椿楀楂楅楋楍楎楔楗-楛楝-楠楢楣楥楦楩-楬楮-楰楷-楹楻-楽榀概-榄榆-榊榎榔-榖榘榛榜榠榡榤-榨榫榭榰榱榴榷榻榼榾槁槃槊槌槎槐槑槔槖様槚-槜槟槠槢槥槪槭槱槲槺-槿樆樊樏樑樕樗樘樛樟-模樧-横樯樱樲樴樵樻樽-樿橁橄橆橇橐橕橘-橛橡橤橥橧橱橹橼橾-檀檃檄檇檍檎檐檑檖檗檠檨檩檫檬檴檵櫆櫌櫜櫡櫹櫽欀欂欃欐欑欙欠-欤欧欨欬欱欲欵-欼款欿歁歃歆-歊歌歓-歕歘歙歛歜歠止-歧歩歪歮-歰歳歴歹-歼歾殁-殄殆-残殍殑-殓殖殗殙-殜殡-殣殥殪殰殳-段殷-殹殻殿毁毂毅毈毉毋母-毛毡毧毫毬毯毳毵毷毹毽毾氄-氇氉氊氍氏-民氓-氝氟氡氢氤-氪氮-氰氲水氵永-氺氽-求汆汇汉-汋汍-汐汔汕汗汙-污汤汧-汪汭汰汲-汴汶汹汽汾沁-沉沌沍沏沐沓-沕沘-沛沟没-沧沩-沮沰沱河沴沷-沿泂泄-泆泉泊泌泐-泗泙-泞泠-泣泥注-泫泭-泳泵泷泸泺-泾洁洄洇洊-洌洎洏洑洒洗洙-洛洞洟洢洣津洧-洫洮洱-洵洸-洿流浃-测浍-浔浙浚浜浠浡浣-浦浩浪浬-浰浴海浸浼浽涂涅消-涊涌涎涐-涕涘涙涛涝-涡涣涤润-涬涮涯液涴-涸涿淀淄-淇淊-淌淑淓淖淘淙淜-淢淤淦淩淫淬淮-深淳混-淹添淼清渇-渎渐渑渓-渗渚渝渟-渥渧-温渫渭-渰渲渴渶游渺渼湃-湅湉湋湍湎湑湓湔湖湘湛-湝湟湢湣湩湫湮湱湲湴湾-満溃溅溆溉溍-源溘溛溜溟溠溢溤-溧溪溮溯溱-溷溺-溾滁-滃滇滉-滋滏滑滓-滕滗滘滚滝-滢滤-滦滨滩滫滮滴滹漂漆漈-漊漎漏漓-漖漘漙漜漠漥漦漩-漫漭漯-漱漳漶漷漼漾潀潄潆潇潋潍-潏潕潗潘潚潜-潠潢潦潭潮潲潴潵潸潺潼-潾澁-澄澈澉澌-澎澐澒澔澙澜澡澣澥-澨澫澬澰澳澴澶澹澼激濂濆-濊濑濒濔濜濞濠濡濩濮濯濲瀁瀌瀍瀑瀒瀔瀚瀛瀡瀣瀬瀳瀵瀹瀺瀼灉灋灌灏灒灖灞灠灢灥灨灪火灭-灰灴-灶灸灺灼灾-炁炅炆炉炊炎炒炔-炙炜炝炤炫-炴炷-点炻-炽烀-烃烈烊烋烓烔烘烙烛-烝烟烤烦-烩烫-热烯烳烷烹烺烽焃焄焉焊焌焐焓焕-焚焜焞焠焢焦焮-焱然焼煁煃煅-煇煊煌-煎煐煕煖煚煜-煠煤煦-煨煮煲煳煸煺煻煽熀熄熅熇熉熊熏熔熘熙熛熜熟熠熤熨熬熯熰熳熵熸熹熿燀燂-燄燊燋燎-燐燔-燖燠燡燥燧燨燮燹燻燽燿爆爇爊爓爚爝爟爨爪爬爯-爱爵-爹爻爽爿-牂牄片版牋-牍牏牒牓牖牙-牛牝牟-牤牦牧物牮牯牲-牵牷-牺牼牾-犂犄犆犇犉犊犍犎犒犗犛犟犠犨-犪犬犮-犰犴-犺狁-狄狆狈狉狍狎狐狒狓狗-狙狝狞狠狡狨狩狫-狴狷狸狺-狼猁猃猇猈猊猋猎猓猕-猘猛-猟猡猢猥猩-献猱-猴猷-猺猾-獀獃獉獍獏獐獒獕獗獙獚獜-獞獠獢獣獧獬獭獯獳獴獾玁玃-玉王玍玎玑玓-玙玛玞-玢玤-玦玩玫玭-现玲玳玶玷玹-玼珀珂珅珇-珊珌珍珏-珑珓珔珖珙珛珞珠珡珣珥珧珩珪班珲珶珷珺珽琀琁球琅-琇琉琏琐琖琚琛琠琢琤-琦琨琪-琶琼瑀-瑂瑄瑉瑑瑔瑕瑗瑙-瑜瑞瑟瑢瑭瑰-瑳瑶瑷瑽-璁璃璅-璈璊璋璎璐璘璚璜-璡璥璧-璫璯璲璸璺璿瓀瓅瓒瓖瓘瓛瓜瓞瓠瓢-瓤瓦瓧瓩瓮-瓱瓴瓶-瓸瓻瓼瓿-甁甃甄甇甋甍-甏甑-甔甖-甚甜生甡産甥用-甮田-电男-画甽-畁畅畇畈畊-界畎畏畑畓畔留-畜畟畤-畧番畯畲-畵畷-畹畽-畿疃疆疋疍-疒疔-疚疝疟-疥疧疫-疯疱-疶疸疹疼-疿痁痂痄病症-痊痌痍痏痐痒痔-痘痚痛痞痠-痤痦-痫痭痯-痵痹痻痼痿-瘁瘃瘅瘆瘈-瘊瘌瘏瘐瘕-瘝瘟瘠瘢瘤-瘦瘨-瘫瘭瘯瘰瘳-瘵瘸瘺瘼瘾瘿癃癈癌癎癐癔癖癙癜癞癠癣癪癫癯癸発登白百皀-的皆-皈皋皌皎皑-皓皕皖皘皙皜-皞皤皦皨皪皫皭皮皱皲皴皻皽皿盂盅盆盈益盋盍-盒盔盖-盘盚盛盝盟盥盦盩盬-盯盱盲直盵相盹盻盼盾省眂眄眅眇-眍眑眕眙-眛眞-眠眢眣眦眨眩眬眭眯眳-眺眼眽着睁睃睅-睇睊睍睎睐-睒睖睙-睛睟-督睥睦睨睪-睬睯睹睽-瞀瞄瞅瞈瞋-瞏瞑-瞓瞕瞖瞟瞠瞢瞤瞥瞧瞩-瞭瞰瞳瞵瞷瞹瞻瞽瞿矉矍矔矗矙矛矜矞-矠矢矣知矧矩矫-矮矰矱石矶矸矻-砃砅砆砉砌砍砑砒研-砗砚砜砝砟砠砢砣砥-砧砩砫-砮砰砳-砵砷-砼砾础硅硇硌-硐硒硕-硗硙硚硜硝硪-确硷硻硼硾碁碃碇碉碌-碏碑碓碔碗碘碚-碜碞碟碡碣碧碪-碬碯-碴碻碾磁磅磈-磋磎磐磔-磖磙磛磟-磡磤磥磨磪磬磲磴磵磷磹-磻礀礁礅礌礐礓礚礜礞礤礧礮礲礴礵示礼-祊祍-祐祓-祘祚-祠祢祥-票祫祭祯祲祷祸祺-祼禀-禂禄禅禇禊禋福禔禖禘禚-禝禠禢禤禥禧禨禫禳禴禸-离禽禾秀私秃秆秈-秋种秏科秒秕秘租秠秣秤秦秧秩-秭积称秷秸移秽秾稀稂稃稊-税稑稔稗稙-稛稞稠稣稬稲稳稷稹稻-稽稿穂穄穆-穉穋穏穑穗穜穟穣穤穧穨穭穮穰穴-空穿-窆窈窊-窍窑窒窔-窘窜-窠窣窥窦窨窬窭窳-窵窸窾窿竁竃竈立竑竖站竜竞-章竣童竦竭端竹竺竽-竿笃笄笆笈-笋笎-笑笓-笕笙笛笞笠笤-符笨笪-笮笰-笳笵笸笺-笼笾筀筅筇-筌筎-筒答策筘筚-筝筠筤-筦筭筮筰-筵筷-筹筼签简箂箊箍箎箐-箕算-箙箛-箝箠管箦-箭箯箱箴箸箾篁篆篇篌篑篓篘-篝篟-篢篥-篨篪篭-篲篴篶篷篹篼篾簁簃簆簇簉簋簌簏簑簖簜簟簠簥-簨簪簬簰簸簻簿-籁籊籍籒-籔籚籣籥籧籫籯米-籵籸籹类-籽粁粉粋粑粒粔粕粗粘粛-粟粢粤粥粧粨粪粮粱-粳粹粻-粿糁糅-糈糊糌糍糒糔-糗糙糜糟糠糢糨糬糯糱糸糺系紃紊紑紞-素索紧紩紫紬累紽紾絁絃絅経絍絏絓絖絘絜絣絪絫絮絰絵絷絺絻絿綀綅綌-綎綖綘-続綦綪綮綯綷緁緅緆緌緎総緑緖緤緪緰縁縃縄縏縕縚縠-縢縦縩縯縰縳縻縿繁繄繇繈繊繋繐繖繘繙繠繣繨繸繻纁纂纆纇纑纕纙-纛纠-纻纽-绕绗-绣绥-绫续-绸绺-缉缋缌缎缏缑-缶缸缺缾罂-罆罋罍-网罔-罘罚罛罝罟-罣罥罦罨-罫罭置署-罴罶罹罻罽-罿羁-羃羇羊羌美羑羔羖羚羜-羟羡-群羧羭-羲羵羶羸羹羼羽羿-翁翃翅翊翌翎翏翔翕翘翚翛翟-翡翣翥翦翩-翫翮-翱翳翻-老考-耇耋-耐耒耔耕耗-耙耜耞耡耤耦-耪耰耳耵-耸耻耽耿聂聃聆聊-聎聒联聘聚聝聡聦聩聪聱聴聼聿肃肄肆肇肉肋肌肏肐肓肕肖肘-肝肟-肢肤肥肧肩-育肴肵肸肺肼-胄胆胊背-胏胑胔胖胗胙-胞胠胡胤-胭胯-胴胶胸-胾脂脆脇脉脊脍脏-脑脓脔脖脘脚脝脞脡-脥脧脩脬脯-脳脶脸脾腆腈腊-腍腐-腕腘腚腜腠腥腧腩腬-腱腴腶腹-膀膂膇膈膊膋膏膑膔膗-膙膛-膝膟膣膦膨膪膫膰膲-膵膷膺膻臀臂-臄臆-臈臊臌臐臑臓臖臙臛-臞臣臧自臬臭臲-致臻-舂舄-舆舋-舎舐舒舔舗舛-舣舨航-舭舰-舻艁艄艅艇艉艋艎艏艑艕-艘艚艜艟艣艨艩艬-艰色-艴艸-艻艾艿节-芄芈芊芋芍-芏芑芒芔芗-芚芜芝芟芡芣-芴芷-芹芼-芿苁苄苇苈苋-苏苑-苕苗-苙苛苜苞-苡苣-苦苪苫苯英苴苶苷苹-苻苾茀-茉茌-茏茑茔-茗茚-茜茞茠茢茥-茨茫-茭茯茱茳-茹茼荀荁荃-草荍荏-荒荔荘荚-荜荞-荡荣-荭药荵荷荸荻-荽莅莆莉莎莒-莕莘-莞莠莦莨-莫莭莰-莴获-莺莼莽莿-菁菅-菇菉菊菌菎-菑菓菔菖菘菜菝菟-菣菥菧菩-菫菰-菲菴菶-菾萁萃-萆萋-萑萘萜萝萣-萩萰萱萴萸萻-落葄葆葇葍葎葑葖著葙-葛葠葡董葥葧葩葫-葭葱葳-葶葸-葺葽蒂蒄蒇蒉蒋蒌蒎蒐蒗蒙蒜蒟蒡蒢蒦蒨蒭蒯蒱蒲蒴蒸-蒻蒽蒿蓁蓂蓄蓆蓇蓉蓊蓌蓍蓏-蓑蓓蓖蓝蓟蓠蓣蓥-蓧蓪-蓬蓰蓱蓷蓺蓼蓿蔀蔂蔃蔆蔇蔉-蔌蔎蔑蔓蔕蔗-蔚蔟蔡蔫蔬蔯蔳蔵蔷-蔾蕃蕈-蕋蕍蕐蕑蕖蕗蕙蕝蕞蕠蕡蕣蕤蕨蕲-蕴蕸-蕻蕾薀薁薃-薇薉薏薐薖薘薛薜薠薢薤薧薨薪-薬薮-薰薳薶-薹薽-薿藁藄藇藉藋藏藐藓藕藘-藚藜藟藤藦藨藩藭藳藴藷藻藾-蘁蘅蘑蘖-蘘蘝蘤蘧蘩蘵蘸蘼虀虆虍-虔虖虚虞虡-虣虥虩虫虬虮虰虱虷虹-蚂蚆蚈蚊-蚍蚓-蚖蚘蚜蚝蚡蚣蚤蚧-蚪蚬蚯-蚱蚳-蚶蚹-蚻蚿-蛁蛄-蛇蛉-蛑蛓蛔蛘-蛜蛞蛟蛡蛣蛤蛩蛭蛮蛰-蛵蛸蛹蛾蜀蜂蜃蜅蜇-蜋蜍蜎蜑-蜓蜕蜗蜘蜚-蜜蜞蜡-蜣蜥蜨蜩蜮蜱蜴蜷蜺蜻蜾-蝀蝃蝇-蝉蝋-蝏蝓蝗-蝙蝝蝠蝡蝣-蝥蝮蝰蝲蝴蝶蝻-蝾螀螂螃螅螈螉螋融螒螓螗-螚螟螣螥螨螫-螭螯螳螵螺螽螾蟀蟅蟆蟊蟋蟏蟑-蟓蟛蟜蟟蟠蟢蟥蟨蟪蟭蟮蟳蟷蟹蟺蟾蟿蠁-蠃蠊蠋蠏蠓蠕-蠗蠙-蠜蠡蠢蠧蠩蠮蠰蠲蠵蠸蠹蠼蠽血衁衄衅衇-衉衋-衎衒衔衖街衙衞衡-衣补表衩衫-衮衰衲衵衷衹衺衽-衿袁袂袄-袆袈袋袍袒袖袗袚袜袟袢袤袪被袭袮袱袲袴袷袺袼袽裀-裂装裆裈裉裋裍裎裒裔裕裘裙裛裟裢-裥裨裯-裴裸裹裼裾褀褂褉褊褎褐褒-褕褙-褛褟褡褢褥-褧褪褫褯-褱褴-褶褽褾襁襄襆襉襋襌襏襕襚-襜襞襟襡襢襦襫-襮襶襻-西要-覃覅覆覉覊覌覗覚覜覧覩覰観见观规-角觔-觖觚觜-觞觡解觥触觩觫觭觯觱觳觷觼-言訇訏訑訒訚訧訬訳訹訾詀詅詈詊詑詗詝詟詨詶詸詹詻誂誃誉-誋誓誙誧説読誯諆諌諕諝諟諴諵謆謇謍謏謑謡謦謪謷謼譅譆譈譊譒譞警譩譬譱譲譸譹讅讆讐讙讟-记讲-论讼-识诈-诩诫-谈谊-谝谟-谷谽豁豆豇豉-豌豏豔-豗豚豜-豞象-豣豦豨豪豫豭豱豳豵-豻貂貅貆貉貊貌貔貘貜貤賏賛賝賨賮賵賸贉贕贝-负贡-赖赘-赤赦赧赫-赭走赱赳-赸趁趂趄超越趋趐-趒趔趟趡趣趦趫趮趯趱足-趵趷-趺趼趾趿跁-跆跋跌跎-跑跕-跗跙-跛距-跟跣跤跦-跬跮路跱-跽踅踆踈-踊踌踏踒踔踖踘踜-踧踩-踬踮踯踱踵踶踹踺踼踽蹀-蹂蹄蹇-蹋蹎蹐-蹔蹙蹚蹜蹝蹠-蹢蹦蹧蹩蹪蹬蹭蹯蹰蹲蹴蹶蹻-蹽蹿躁躃-躅躇躏躐躔躗-躙躜-躞躠躧躩身-躭躯躰躲躶躺軃軆軏軘軜軝転軥軨軭軱軷軽軿輀輂輈輗輠輤輬-輮輴-輶輹輼轇轏轑轒轕-轙轝轞车-轩轫-轶轸-轿辁-辋辍-辜辞辟辣辨辩辫辰辱辵辶边辺込-辿迁迂迄迅过迈迋迍迎运近迓-迕还这进-迟迢-迦迨-迫迭迮述迳迷-迻追迿-逆选-逍透-途逖逗通逛逝-逢逦逭-逯逴-逶逸逹逻逼逾遁遂遄遅遇遍遏-道遗遘遛遝遢遣遥遨遫遭-遰遴遵遹遻遽避邀邂邃邅邈邉邋邎邑邓邕邗-邙邛邝邠-那邦-邨邪邬邮-邻邽-邿郁郃-郅郇郈郊郎-郑郓-郕郗郙-郞郠-郢郤郦-部郪郫郭郯郰郲-郴郷-郹都-鄀鄂鄄鄇鄈鄋鄍-鄑鄕鄗-鄚鄜鄞鄠鄢-鄤鄦鄩鄫鄬鄮鄯鄱鄷鄹鄻鄾鄿酃酅-酇酉-酐酒酔-酗酚酝酞酡-酦酩酪酬酮-酲酴-酺酽-酿醁醄-醇醉-醍醐-醓醖醚醛醝醡-醤醨醪醭-醰醲醴醵醸-醺醼-醾釂釆-释里-量金釜釪釬釭釱釳釸鈃鈆鈇鈊鈌鈒鈤鈬鉄鉆鉌鉏鉥鉨鉱鉲鉴鉶鉼鉾銍銎銕銤銧銭銮銰銶鋂鋆鋈鋊鋍鋐鋑鋕鋘鋙鋭鋳鋹鋺錀錍錔錞錤錩錬録錼錾鍉鍏鍐鍚鍪鍫鍭鍱鍴鍹鎉鎋-鎍鎏鎒鎓鎗鎚鎞鎤鎭鎯鎴鎸鎹鏊鏖鏚鏠鏦鏸鏻鏽鏾鐄鐇鐏鐗鐡鐩鐬鐱鐶鐻鐽鑀鑅鑐鑕鑚鑛鑢鑤鑪鑫鑯鑱鑴鑵钃钆-钐钒-钕钗钙-铎铐-铗铙铛-铝铟-铳铵-铺铼-锌锎-锟锡-锦锨锩锫-锲锴-镊镌-镘镚-镨镪-镭镯-镴镶镻长閒閗閟関閤閦閲閺闉闑闒闘闚闟闠闤门-阒阔-阗阙阚阜阞队阡阢阤阨阪阬阮阯阱-阶阹阻-阽阿-陂附-陉陋-降限陑陔陕陛陜陟陡院除陥陧-陪陬陲陴-陷険陼陾隃隅隆隈隋隍随隐隒隔隗-隙障隞隠隣隤隧隩隮隰隳隶隷隹隼-难雀-雂雄-雊雌-雏雑雒雕雗雘雚雝雟雠雨-雪雯-雱雳零雷雹雾需-霂霄-霊霍-霏霒霓霖霙霜-霞霢-霤霨-霫霭霮霰露霸霹霾靁靑-靓靖静靛非靠-靣靥革靪靬靮靰靳靴靶-靸靺靼靿鞀鞃-鞅鞋鞍鞑鞗-鞚鞝鞞鞠鞡鞣鞨鞫-鞯鞶鞹鞾韅韍韎韔韖韘韝韡韣韦韧韩-韭韱音韵韶韹韺頀頄頍頖頞頠頫頬頯頲頼顋顑顕顗顚顜顣页-颊颌-频颓-颢颤-颧颸颽-飀飂飌风-飓飕飖飘-飚飞食飡飣飥飧飨飮飶餀餂餇餈餍餐餖餗餚餟餠餤餧餩-餫餮餲餸饇饎饐饔饕饘饟饥饧-饲饴-饺饼饽饿-馆馈馊-香馝馡馣馥馨馵馹駃-駆駉駋駓駗駜駪駬駴駹駽駾騂-騄騆騉騋騑-験騕騠騢-騤騧騵騺驆驈驌驎驒驔驖驙驦驩驫-驱驳-骈骊-验骎-骓骖-骘骚-骥骧骨骫骭骰骱骴骶-骸骺骼骾髀-髂髄-髇髋髌髑髓高髙髝-髟髡髣髦髧髪髫髭髯髲髳髹-髻髽髾鬁鬃鬅鬈鬋鬎-鬓鬖-鬙鬟鬠鬣鬫鬬鬯鬰鬲鬵鬷鬻鬼魁-魋魍魏魑魔魖魛魟魠魣魦魨魬魵魸鮀鮆鮓鮟鮠鮦鮨鮶鮸鮿鯄鯆鯈鯕鯙鯠鯥鯸鰋鰕鰛鰜鰤鰦鰶鰼鰽鱀鱄鱆鱇鱎鱐鱠鱨鱮鱲鱵鱻鱼鱿鲁-鲃鲅-鲈鲋鲍-鲒鲔鲕鲗鲚-鲜鲞-鲩鲫鲭鲮鲰-鲳鲵-鲸鲻-鲽鳀鳁鳃-鳇鳊鳌-鳑鳓-鳗鳙鳜-鳟鳢鳣鳦鳯鳲鳷鳻鴂-鴄鴈鴎鴔鴗鴠鴢鴥鴳鴷鴽鵀鵁鵖鵙鵟鵩鵫鵵鵷鵻鶂鶊鶏鶒鶗鶡鶤鶦鶬鶱鶵鶸鶹鶿鷁鷃鷄鷇鷊鷏鷕鷞鷟鷩鷫鷭鷾鸂鸇鸏鸑-鸓鸜鸟-鸣鸥鸦鸨-鸻鸽-鸿鹁-鹏鹑鹕鹗-鹚鹜鹞鹟鹡鹣-鹧鹩-鹮鹰鹳鹸鹾-麀麂-麄麇麈麋麌麐-麓麚麛麝麟麤麦麫麮-麰麴麸麺麻麽-麿黁黄黈黉黍-黕默黙黛-黝黟黠黢黥-黧黩黪黮-黱黶黹黻黼黾鼂-鼅鼇鼈鼋鼍-鼐鼒鼓鼖鼙-鼛鼠-鼢鼩-鼬鼯鼱鼷鼹鼻鼽鼾齁齆-齉齌齐齑齕齗齚齞齢齧齩齮-齱齵齾-龀龃-龌龑龒龖龘-龛龝龟-龢龤]";
final String string = "Online regex tester, debugger with highlighting for PHP, PCRE, Python, Golang and JavaScript.\n"
+ "You've visited this page 2 times. Last visit: 21/08/20\n"
+ "People also search for\n"
+ "regex tutorial\n"
+ "regex c#\n"
+ "regex python\n"
+ "regex cheat sheet\n"
+ "This free regular expression tester lets you test your regular expressions against any entry of your choice and clearly highlights all matches. It is JavaScript based ...\n\n"
+ "测试测试测试测试\n\n"
+ "1.5 新闻动态\n"
+ "阿列克謝·納瓦爾尼\n"
+ "俄羅斯反對派反对派領袖阿列克謝·納瓦爾尼(圖)在從托木斯克返回莫斯科途中感到不適,其後被送到鄂木斯克醫院急救。\n"
+ "全球各地在2019冠状病毒病疫情期間的累計確診人數突破2,200萬人,並造成至少78.1萬人死亡。\n"
+ "美國民主黨全國代表大會正式提名前副總統乔·拜登為民主黨在總統選舉的候選人。\n"
+ "马里武裝部隊在首都巴馬科發動軍事政變,其後總統易卜拉欣·凱塔宣布辭職、解散政府和國民議會。\n"
+ "英國台球選手罗尼·奥沙利文以18比8擊敗奇倫·威爾森,贏得2020年世界斯诺克锦标赛冠軍。\n"
+ "最近逝世:斯雷德·戈登-鮑里斯·巴頓-馬達夫·普拉薩德·吉米瑞-切薩萊·羅米蒂-本·克羅斯\n\n"
+ "文化審議会は2010年6月7日、改定常用漢字表(2136字/4388音訓[2352音・2036訓])を答申した。これは同年11月30日に平成22年内閣告示第2号「常用漢字表」として内閣告示された。その際、昭和56年内閣告示第1号「常用漢字表」は廃止された。";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}