use strict;
my $str = 'Online regex tester, debugger with highlighting for PHP, PCRE, Python, Golang and JavaScript.
You\'ve visited this page 2 times. Last visit: 21/08/20
People also search for
regex tutorial
regex c#
regex python
regex cheat sheet
This free regular expression tester lets you test your regular expressions against any entry of your choice and clearly highlights all matches. It is JavaScript based ...
测试测试测试测试
1.5 新闻动态
阿列克謝·納瓦爾尼
俄羅斯反對派反对派領袖阿列克謝·納瓦爾尼(圖)在從托木斯克返回莫斯科途中感到不適,其後被送到鄂木斯克醫院急救。
全球各地在2019冠状病毒病疫情期間的累計確診人數突破2,200萬人,並造成至少78.1萬人死亡。
美國民主黨全國代表大會正式提名前副總統乔·拜登為民主黨在總統選舉的候選人。
马里武裝部隊在首都巴馬科發動軍事政變,其後總統易卜拉欣·凱塔宣布辭職、解散政府和國民議會。
英國台球選手罗尼·奥沙利文以18比8擊敗奇倫·威爾森,贏得2020年世界斯诺克锦标赛冠軍。
最近逝世:斯雷德·戈登-鮑里斯·巴頓-馬達夫·普拉薩德·吉米瑞-切薩萊·羅米蒂-本·克羅斯
文化審議会は2010年6月7日、改定常用漢字表(2136字/4388音訓[2352音・2036訓])を答申した。これは同年11月30日に平成22年内閣告示第2号「常用漢字表」として内閣告示された。その際、昭和56年内閣告示第1号「常用漢字表」は廃止された。';
my $regex = qr/[㠯㵎㼝䠶䰾䳘丟亂亙亞亾佀佇佈佔來侖侷俁俠俲俻倀倆們倖偪傌傖傚傭傯傳傴僂僉僑僞僥僨僱價儂儈儉儐儔儕儗儘儲儷儸儺-儼兇兌兒兗內兩冪凈凜凱刦刧刪刼剄剉剋剎剝剮剴剷劃劄劉劊劌劍劑勁勛勞勣勦勱勳勵勸勻匭匯匱區卹卻厙厠厭厲厴參叢吳吶咷咼哶唚啞啟啣喬單喲嗆嗇嗎嗚嗩嗶嘊嘍嘓嘔嘖嘗嘜嘩嘮-嘰嘵嘷嘸嘽噁噓噝噠噥噦噯噲噸噹嚀嚌嚐嚕嚙嚥嚦嚨嚲-嚴嚶囀-囂囅囈囉囌囑囪圇國圍圓圖團埡堊堖堝堯塋塏塒塢塤塲塵塹墊墮墻壓壘-壚壞-壠壢壩壯壺壼壽夠夾奐奧奩奼妝姍姦姪娛婁婭媧媯媼媽嫋嫗嫵嫻嬀嬈嬋嬌嬙嬝嬡嬤嬪嬰嬸孃孌學孿宂寢實寫寬寳寵寶將專對尒尷屆屍屓屜屢屨屬屭峩峯峴峽崍崐崑崗崙崢崬嵗嶁嶃嶄嶇嶔嶗嶠嶧嶴嶸嶺嶼嶽巋巒巔巖巹帬帶幀幃幇幗幘幚幟幫幬廁廂廄廈廕廚廝廟-廣廩廬廳廹弒弳彆彈彊彌彎彞彠彥彿徑從徠怳恆悅悳悵悶悽惡惥惪惱惲惷惻愙愜愨愴愷愾慂慍慘慚慟慪慫慳慼慾憊憐-憒憚憫憮應懌懍懟懣懨懶懷懺懼懾戀戇戔戞戧戩戰戲戶戼抝拋挾捫捲掄掙揀揹搖搗搯搵搶摑摜摟摳摶摻撈撏撐撓撝撟撣撥撧撫撳撻撾撿擄擇擊擋擔據擠擯-擲擴擷擺-擼擾攄攆攏攔攖攙攛-攝攢-攤攪攬敍敘敱數斂斃斕斷旂旹昰晉晝暈暉暘暢暱曄曆曉曠曡曨曬會朧朶栢桮桿梔梘條梟棖棗棧棲椀椏楄楊楓楨楳榪榮榿槍槓槤槧槨槮槳樁樂樅樓樞樣樸樺橈橢橫檁檉檔檜檟檢檣檮檯檳檸檻櫂櫃櫓櫚櫛櫝-櫟櫥櫧櫨櫪-櫬櫱櫳櫸櫺櫻權欏欒欖欞欽歎歐歟歡歲歷歸歿殀殘殞殤殫殭-殯殲殼殽毆毿氂氈氌氣氫氬氳沒洶浹涇涖淒淚淥淨淪淵淶淺渙渾湊湞湼溈溫滄滌滎滙滬滯滲滷滸滻滾滿漚漣漲漵漿潁潑潛潯潷潿澀澆澇澗澠澤澮澱濕濘濛濟濤濬濰濱濺濼濾瀅瀆瀉瀋瀏瀕瀘瀝瀟瀠瀦-瀨瀰瀲瀾灃灄灑灕灘灝灣灤灩烏烴煉煒煗煢煥煬熒熗熲熾燁燈燉燒燙燜營燦燬燭燴燼燾爍爐爛爭爲爺爾牆牎牕牘牽犖犢犧狀狹狽猙猻獁獅獎獘獨獪獫獮獰獵獷獸獺-獼玀玨珮琊琹琺琿瑋瑣瑤瑩瑪瑯璉璣璦璵瓊瓏瓔瓚甌甕產甦甯畢畫畬當疇疉疊痙痺痾瘂瘋瘓瘞瘡瘧瘮瘲瘻癆癇癉癘癟癡癢癤癥癧癩癬-癮癰-癲發皐皚皰皸皺盃盌盜盞盡盧盪眥眾睏睜睞睺瞇瞘瞜瞞瞼矇矓矚硃硤硨硯碩碭碸碼磑磚磣磧磯磽礄礆礙礡礦礪-礬礱祿禎禑禕禡禦禪禮禰禱禿秌稅稈稜稟稭稱稾穌穎穠-穢穩窩窪窰窶窺窻竄竅竇竊竝竪筍筧筩筯箏篋篔篩篳簀簍簞簣簫簷簹簽簾籃籌籐籖籙籛籜籟籤籩籪籬籮籲粃粵粺糝糞糭糰糲糴糶紂紆-紉紐紓紕紗紘紜紝紥紮紱紲紵紼紿絀絆絎絕絛絝絢絨絲絳綁綃綆綈綉綏綑經綜綠綢綣綫綬綰綴綵綸-綺綽綾緄緇緋緔緗-緙緜-緞緡緣緥緦緬緱緲緶緹縈-縋縐縑縗縝-縟縣縧縭縱縲縴-縷縹總繃繅繆繒繚繞繡繢繩-繫繮繯繳繹繼-繾纈-纊續纍纏纓纔纖纘纜缽罈罌羆羈羋羗羥翄翬翹翺耑耬聯聰聲聳聵聶聹聽聾肅肈脛脫脹腖腡腦腳膃膆膕膠膩膽-膿臉臍臏臕臘臚臟臠臢臥臺與舉舊舖舘艙艤艫艱艷芻苧茲荊荳莊莖莢莧菕萇萊萬萵萹葒葦葯葷蒓蒔蒞蒼蓀蓮蓯蓴蓽蔔蔞蔣蔥蔦蔭蔴蕁蕆蕎蕒蕓蕕蕘蕢蕩蕪蕭蕷薈薊薌薑薔薙薩薺藎藝藥藪藶藹藺蘄蘆蘇蘊蘋蘚蘞蘢蘭蘺蘿處虛號虧虯虵蛺蛻蜆蝕蝟蝦蝨蝯蝱蝸螄螞螢螮螻螿蟄蟈蟎蟣蟬蟯蟲蟶蟻蠅蠆蠍蠐蠑蠔蠟蠣蠨蠭蠱蠶蠻衂衊衕衚袞裊裌裝裡褌褘褭褲褳褸褻襃襇襖襝襠襤襪襯襴覈覓覘覡覥覦覬覯覲覷覺覽覿觀觴觶觸訊訌訐訕訖訛訝訢訣訥訶註詁詆詎詒詖詘詛詡詢詧詫-詭詵詼詿誄-誆誑誒誖誚誡誣誥誦誨說誶誹誼誾諂諄諉諍諏諑諒諗諛諜諞諠-諢諤諫諱諳諶諷諺諼謂謅謊謌謐謔謖謗謚謠謨謫謬謳謾譁證譌譎譏譔譖譙譚譟譫譭譯譴譽譾讀變-讌讎讒讓讕讖讚讜讞谿豈豎豐豬貍貎貓貙貰貲貳貶貺貽賁賅賈賑賒賕賙賚賡賣賤賧賫賬賴賺賻賽賾贄贅贇贊贍贏贐贓贔贖贗贛趕趙趨趲踐踰踴蹌蹕蹟蹣蹤蹺躂躉-躋躑-躓躕躚躛躡躥躦躪躳軀軋軔軛軫軲軹-軼軾輅輇輊輒-輕輙輛輜輞輟輥輦輯輳輻輾-轀轂轅轆轉轍轎轔轟轡轢轤辠辢辤辦辭-辯迴逕這遉遙遞遲遶遼邁邇邊邏邐郟鄆鄉鄒鄔鄖鄧鄭鄰鄲鄴鄶鄺酈醃醞醫醬醱釀釁釃釅釋釐釓-釕釗-釙釤釦釧釩釵釷釹釺鈀鈁鈄鈈鈉鈎鈐鈑鈔鈕鈞鈣鈥-鈧鈮鈰鈳鈷-鈺鈽-鉀鉅鉈鉉鉋鉍鉑鉕鉗鉚鉞鉤鉦鉬鉭鉸鉺鉻鉿銑銓銖銚-銜銠銣銥銦銨-銬銲銳銷銹銻銼銾鋁鋃鋅鋇鋌鋏鋒鋝鋟鋤-鋦鋨-鋪鋮-鋱鋸鋻錁錄錆-錈錏錐錒錕錘-錛錟錡錢錨錫錳錶錸鍀鍁鍆鍇鍊鍍鍔鍘鍠鍤鍥鍩鍬鍰鍶鍺鍼鍾鎂鎄鎇鎊鎔鎘鎛鎡-鎣鎦鎧鎩鎪鎬鎰鎳鎵鎿鏃鏇鏈鏌鏐鏑鏗鏘鏜-鏟鏢鏤鏨鏰鏵鏷鏹鐃鐐鐒-鐔鐙鐝鐠鐦-鐨鐫鐮鐲鐳鐵鐸鐺鐿鑄鑊鑌鑒鑔鑞鑠鑣鑥鑭鑰鑲鑷鑼-鑿钁閂閃閆閈閌閎閏閔閘閡閧-閩閫-閭閱閶閹閻-閿闃闆闈闊-闍闐闓-闖關闞闡闢闥陘陝陞隂隄隉隕隨險隱隴隸雋雖雙雛雜雞霑霽靂靄靆靈靉靚靜靦靨鞌鞏鞦韁韃韆韉韋韌韙韜韞韮頁頇頊頌頎頏頗頜頡頤頦頰頴頷-頹顆顇顏顒顓顙顛顢顥顫顬顯-顱顳顴颭-颯颱颳颶颺-颼飄飆飈飜飤飩-飫飭飱飴餃餄餉餎餑餒餔餕餘餛餜餞餡餬餱餳餵餺-餿饁饃饅饈-饍饑饒饗饜饞饢馭馮馱馳馴駁駑駔駕駘駙駛駝駟駡駢駭駮駰駱駸駿騁騅騍騏騖騙騫騭騮騶-騸騾驀-驅驊驍驏驕驗驛驟驢驤驥驪骯髈髏髐髒體-髖髮鬆鬍鬚鬢鬥鬧-鬪鬭鬮魎魘魯魴魷鮁鮃鮌-鮎鮐-鮒鮚鮞鮪鮫鮭鯀鯁鯇鯉鯊鯔鯖鯗鯛鯡鯢鯤鯧鯪鯫鯰鯷鯽鯿鰂鰆鰈鰉鰍鰐鰒鰓鰟鰣鰥鰨鰩鰭鰮鰱-鰳鰷鰹鰻鰾鱅鱈鱉鱒-鱔鱖-鱘鱝鱟鱣鱧鱭鱷鱸鱺鳧鳩鳳鳶鴆鴇鴉鴒鴕鴛鴝-鴟鴣鴦鴨鴯鴰鴴鴻鴿鵂鵑-鵓鵜-鵞鵠鵡鵪鵬鵯鵰鵲鵾鶇鶉鶓鶖鶘鶚鶩鶯鶲鶺-鶼鷀鷂鷈鷉鷓鷖鷗鷙鷥鷦鷯鷲-鷴鷸-鷺鷽鷿鸊鸕鸚鸛鸝鸞鹵鹹鹺鹼鹽麥麩麪麵麼黃黌點黨黲黴黷黽黿鼉鼕鼴齊齋齎齏齒齔齙齜齟-齡齣齦齪齬齲齶齷龍龎龐龔龕龜]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}