$re = '/(Hello)\s(World)\.\s(Hi)\s\2\./m';
$str = 'Hello World. Hi World.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);