package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d+\.\d+\.)(\d+)`)
var str = `1.01.1
1.01.2
1.01.3
1.02.1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}