#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ums)(*napla:.{1,300}$\R?(.*\z))(?>\N*\R?){0,5}(?=\1)"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. In sed lacus tempus, consequat turpis dapibus, gravida sapien. Praesent venenatis venenatis dui sed mattis." & @CRLF & _
"Phasellus id ultrices lorem. Donec volutpat efficitur ullamcorper. Cras a vehicula tortor. ___" & @CRLF & _
"Interdum et malesuada fames ac ante ipsum primis in faucibus." & @CRLF & _
"Etiam quis sapien eget mi fringilla cursus vitae a velit." & @CRLF & _
"Praesent non mi nulla." & @CRLF & _
"Morbi imperdiet risus felis, at fermentum diam ultricies et." & @CRLF & _
"Mauris leo sem, efficitur a sollicitudin ac, dapibus ut orci. ___" & @CRLF & _
"Sed a venenatis augue. " & @CRLF & _
"Eget placerat nunc." & @CRLF & _
"Nunc a fringilla ex." & @CRLF & _
"Vestibulum accumsan ullamcorper purus id consectetur. Duis quis velit mauris." & @CRLF & _
"Sed interdum magna ac purus aliquam, at interdum erat finibus. ___" & @CRLF & _
"" & @CRLF & _
"Aenean ut nisl dignissim, lobortis risus ut, fringilla libero. Fusce at eros a mauris tristique laoreet sit amet at velit. " & @CRLF & _
"Class aptent taciti sociosqu ad litora torquent per conubia nostra, per inceptos himenaeos. Praesent ac condimentum velit." & @CRLF & _
"Nunc condimentum vulputate mauris et tincidunt. ___" & @CRLF & _
"Nullam consectetur tincidunt ex, in placerat ligula molestie et." & @CRLF & _
"Praesent lacus justo, scelerisque ac iaculis tristique, malesuada quis nisl." & @CRLF & _
"Sed mattis pellentesque elit. Nulla facilisis tellus sed eros efficitur pellentesque venenatis vitae dui. ___"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")