#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)((https?:)?\/\/)?(([\d\w]|%[a-fA-f\d]{2,2})+(:([\d\w]|%[a-fA-f\d]{2,2})+)?@)?([\d\w][-\d\w]{0,253}[\d\w]\.)+[\w]{2,63}(:[\d]+)?(\/([-+_~.\d\w]|%[a-fA-f\d]{2,2})*)*(\?(&?([-+_~.\d\w]|%[a-fA-f\d]{2,2})=?)*)?(#([-+_~.\d\w]|%[a-fA-f\d]{2,2})*)?"
Local $sString = "www.google.com" & @CRLF & _
"" & @CRLF & _
"https://www.google.com" & @CRLF & _
"" & @CRLF & _
"http://www.google.com" & @CRLF & _
"" & @CRLF & _
"mailto:somebody@google.com" & @CRLF & _
"" & @CRLF & _
"somebody@google.com" & @CRLF & _
"" & @CRLF & _
"www.url-with-querystring.com/?url=has-querystring" & @CRLF & _
"" & @CRLF & _
"sadasdasd.co.uk" & @CRLF & _
"http://google.fr" & @CRLF & _
"http://www.google.fr" & @CRLF & _
"https://google.fr" & @CRLF & _
"https://www.google.fr" & @CRLF & _
"du texte" & @CRLF & _
"http://google" & @CRLF & _
"https://google" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")