$re = '/\.set\((.+,\s?){2}(.+)\)/';
$str = 'm.set("foo",BAR, true)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);