$re = '/:(?:122|194|945):[^:]+:/m';
$str = '1:one:2:two:....:122:twentytwo:....:194:ninetyfour:....';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);